summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD17
2 files changed, 8 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 176bf575e394..8844957967ba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = nothing
pkgdesc = A game about nothing
- pkgver = r2509.5053d9c
+ pkgver = r2894.95ca07bd
pkgrel = 1
url = https://github.com/tsoding/nothing
arch = x86_64
license = MIT
makedepends = gcc
- makedepends = cmake
depends = sdl2
provides = nothing
conflicts = nothing
diff --git a/PKGBUILD b/PKGBUILD
index 484818f18a38..72bc2ed18c96 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Gokberk Yaltirakli <aur at gkbrk dot com>
pkgname=nothing
_pkgname=nothing
-pkgver=r2509.5053d9c
+pkgver=r2894.95ca07bd
pkgrel=1
epoch=
pkgdesc="A game about nothing"
@@ -9,7 +9,7 @@ arch=('x86_64')
url="https://github.com/tsoding/nothing"
license=('MIT')
depends=('sdl2')
-makedepends=('gcc' 'cmake')
+makedepends=('gcc')
provides=('nothing')
conflicts=('nothing')
source=("nothing::git+$url")
@@ -31,11 +31,9 @@ prepare() {
build() {
cd "$srcdir/$_pkgname"
- rm -rf build
- mkdir build
- cd build
- cmake ..
- make
+ export CFLAGS="$CFLAGS -flto -Ofast"
+ export CC="cc"
+ ./build-posix.sh
cat > "nothing-with-dir" <<EOF
#!/bin/sh
@@ -51,10 +49,9 @@ check() {
package() {
cd "$srcdir/$_pkgname"
- ls assets/
install -Dm755 -d "$pkgdir/usr/share/games/nothing"
cp -r assets/ "$pkgdir/usr/share/games/nothing"
- install -Dm755 "build/nothing" "$pkgdir/usr/lib/games/nothing/nothing"
- install -Dm755 "build/nothing-with-dir" "$pkgdir/usr/bin/nothing"
+ install -Dm755 "nothing" "$pkgdir/usr/lib/games/nothing/nothing"
+ install -Dm755 "nothing-with-dir" "$pkgdir/usr/bin/nothing"
}