summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e29d5b7938e6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = notification-mount-git
+ pkgdesc = Script to show notification for a block device with mount option
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/patrick96/notification-mount
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = python
+ depends = python-gobject
+ depends = python-notify2
+ depends = udevil
+ provides = notification-mount
+ conflicts = notification-mount
+ source = notification-mount::git+https://github.com/patrick96/notification-mount.git
+ md5sums = SKIP
+
+pkgname = notification-mount-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e185a970fe6a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Patrick Ziegler <p.ziegler96 at gmail dot com>
+_pkgname="notification-mount"
+pkgname="${_pkgname}-git"
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="Script to show notification for a block device with mount option"
+arch=('any')
+url="https://github.com/patrick96/$_pkgname"
+license=('GPL3')
+depends=('python' 'python-gobject' 'python-notify2' 'udevil')
+makedepends=('git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("${_pkgname}::git+${url}.git")
+md5sums=("SKIP")
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -D -m755 "./notification-mount" "$pkgdir/usr/bin/notification-mount"
+ install -D -m644 ./examples/notification-mount.service \
+ "$pkgdir/usr/lib/systemd/user/notification-mount.service"
+}
+
+# vim:set ts=2 sw=2 et: