summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 325da6ed74bd..cff1948ca406 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = notion-app
pkgdesc = The all-in-one workspace for your notes and tasks
pkgver = 1.0.5
- pkgrel = 1
+ pkgrel = 2
url = https://www.notion.so/desktop
arch = i686
arch = x86_64
license = MIT
makedepends = dmg2img
makedepends = p7zip
+ makedepends = libicns
+ makedepends = gendesk
depends = electron
source = https://desktop-release.notion-static.com/Notion-1.0.5.dmg
source = notion-app
diff --git a/PKGBUILD b/PKGBUILD
index 9ee06cb377c3..9e19b637ecb6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
pkgname=notion-app
pkgver=1.0.5
-pkgrel=1
+pkgrel=2
pkgdesc="The all-in-one workspace for your notes and tasks"
arch=('i686' 'x86_64')
url="https://www.notion.so/desktop"
license=('MIT')
depends=('electron')
-makedepends=('dmg2img' 'p7zip')
+makedepends=('dmg2img' 'p7zip' 'libicns' 'gendesk')
source=("https://desktop-release.notion-static.com/Notion-"${pkgver}".dmg" 'notion-app')
md5sums=('e742641e62819e7ffe48c5cae09c4ee1'
'c6e87309eebe3dfdd206e4c399fffebb')
@@ -22,6 +22,8 @@ build() {
7z x -y "Notion-"${pkgver}".img" >/dev/null
cp -r Notion**/Notion.app/Contents/Resources/* tmp/build
cp notion-app tmp/build
+ icns2png -x tmp/build/Notion.icns
+ gendesk -f --pkgname="Notion" --pkgdesc="$pkgdesc" --categories=Office --exec=notion-app --icon=/opt/notion-app/Notion_512x512x32.png
}
package() {
@@ -29,5 +31,6 @@ package() {
mkdir -p "$pkgdir/usr/bin" "$pkgdir/opt/notion-app"
cp -r tmp/build/* "$pkgdir/opt/notion-app/"
install -D -m755 notion-app "$pkgdir/usr/bin/notion-app"
+ install -Dm644 "$srcdir"/Notion.desktop -t "$pkgdir"/usr/share/applications
}