summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD18
-rw-r--r--noto-fonts-sc.install15
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..13861b26c4d9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = noto-fonts-sc
+ pkgdesc = Noto CJK-SC fonts for Simplified Chinese
+ pkgver = 20150617
+ pkgrel = 1
+ url = https://github.com/googlei18n/noto-cjk
+ install = noto-fonts-sc.install
+ arch = any
+ license = custom: SIL
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = https://github.com/googlei18n/noto-cjk/raw/master/NotoSansCJKsc-DemiLight.otf
+ sha256sums = SKIP
+
+pkgname = noto-fonts-sc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..518aaf03fdf9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: halflife <pigoig_At_gmail_com>
+
+pkgname=noto-fonts-sc
+pkgver=20150617
+pkgrel=1
+pkgdesc="Noto CJK-SC fonts for Simplified Chinese"
+arch=(any)
+depends=(fontconfig xorg-font-utils)
+source=("https://github.com/googlei18n/noto-cjk/raw/master/NotoSansCJKsc-DemiLight.otf")
+url="https://github.com/googlei18n/noto-cjk"
+install=${pkgname}.install
+license=("custom: SIL")
+sha256sums=('SKIP')
+
+package() {
+ install -d "${pkgdir}/usr/share/fonts/OTF"
+ install -m644 "${srcdir}/"*.otf "${pkgdir}/usr/share/fonts/OTF/"
+}
diff --git a/noto-fonts-sc.install b/noto-fonts-sc.install
new file mode 100644
index 000000000000..477228553e82
--- /dev/null
+++ b/noto-fonts-sc.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -fs >/dev/null
+ mkfontscale /usr/share/fonts/OTF
+ mkfontdir /usr/share/fonts/OTF
+ echo "done"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}