summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO80
-rw-r--r--PKGBUILD106
-rw-r--r--nova-api.service9
-rw-r--r--nova-cert.service9
-rw-r--r--nova-compute.conf7
-rw-r--r--nova-compute.service10
-rw-r--r--nova-conductor.service9
-rw-r--r--nova-consoleauth.service9
-rw-r--r--nova-novncproxy.service9
-rw-r--r--nova-scheduler.service9
-rw-r--r--nova.install23
-rw-r--r--nova_sudoers3
12 files changed, 283 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..19a999165d57
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,80 @@
+pkgbase = nova-liberty
+ pkgdesc = OpenStack cloud computing fabric controller
+ pkgver = 12.0.0.0b1
+ pkgrel = 1
+ url = https://launchpad.net/nova
+ install = nova.install
+ arch = any
+ license = custom
+ makedepends = python2-setuptools
+ depends = python2-pbr>=0.11
+ depends = python2-pbr<2.0
+ depends = python2-sqlalchemy-openstack
+ depends = python2-boto>=2.32.1
+ depends = python2-decorator>=3.4.0
+ depends = python2-eventlet>=0.17.3
+ depends = python2-jinja>=2.6
+ depends = python2-keystonemiddleware-liberty
+ depends = python2-lxml>=2.3
+ depends = python2-routes>=1.12.3
+ depends = python2-webob>=1.2.3
+ depends = python2-greenlet>=0.3.2
+ depends = python2-paste-deploy>=1.5.0
+ depends = python2-paste
+ depends = python2-migrate-openstack
+ depends = python2-netaddr>=0.7.12
+ depends = python2-netifaces>=0.10.4
+ depends = python2-paramiko>=1.13.0
+ depends = python2-pyasn1
+ depends = python2-babel>=1.3
+ depends = python2-iso8601>=0.1.9
+ depends = python2-jsonschema>=2.0.0
+ depends = python2-jsonschema<3.0.0
+ depends = python2-cinderclient-liberty
+ depends = python2-keystoneclient-liberty
+ depends = python2-neutronclient-liberty
+ depends = python2-glanceclient-liberty
+ depends = python2-requests>=2.5.2
+ depends = python2-six>=1.9.0
+ depends = python2-stevedore-openstack
+ depends = python2-setuptools
+ depends = websockify>=0.6.0
+ depends = websockify<0.7
+ depends = python2-oslo-concurrency-liberty
+ depends = python2-oslo-config-liberty
+ depends = python2-oslo-context-liberty
+ depends = python2-oslo-log-liberty
+ depends = python2-oslo-serialization-liberty
+ depends = python2-oslo-utils-liberty
+ depends = python2-oslo-db-liberty
+ depends = python2-oslo-rootwrap-liberty
+ depends = python2-oslo-messaging-liberty
+ depends = python2-oslo-i18n-liberty
+ depends = python2-rfc3986>=0.2.0
+ depends = python2-oslo-middleware-liberty
+ depends = python2-psutil-liberty
+ depends = python2-oslo-versionedobjects-liberty
+ depends = python2-alembic>=0.7.2
+ source = https://launchpad.net/nova/liberty/liberty-1/+download/nova-12.0.0.0b1.tar.gz
+ source = nova-api.service
+ source = nova-cert.service
+ source = nova-conductor.service
+ source = nova-consoleauth.service
+ source = nova-novncproxy.service
+ source = nova-scheduler.service
+ source = nova_sudoers
+ source = nova-compute.conf
+ source = nova-compute.service
+ md5sums = 19e83fbb542cdcd4b464c3d2984e102e
+ md5sums = 5345f34af3bcc5b5b142bc1545821045
+ md5sums = 85d6229bd6336a074d6b9f284bab560d
+ md5sums = afff9d985f64b2d0403574f73fde7fdf
+ md5sums = 37d1fd1dd4724531d583a603a0185653
+ md5sums = 43d3516a9b1a53851bbcb0dcee0269d4
+ md5sums = 90d17720783c89a1d2d113e560bafab8
+ md5sums = b166058b5c25d0d7851adf30c2356691
+ md5sums = c15ecc2982a90c2a86c110833c6c4bbc
+ md5sums = e16fbaef08ba9fc08a726425d0c79429
+
+pkgname = nova-liberty
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0580de675f71
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,106 @@
+# Maintainer: Erhan SAHIN <erhan@ssahin.net>
+
+pkgname=nova-liberty
+osseries=liberty-1
+pkgver=12.0.0.0b1
+pkgrel=1
+pkgdesc="OpenStack cloud computing fabric controller"
+arch=(any)
+install=nova.install
+url=https://launchpad.net/nova
+license=(custom)
+depends=('python2-pbr>=0.11'
+ 'python2-pbr<2.0'
+ 'python2-sqlalchemy-openstack'
+ 'python2-boto>=2.32.1'
+ 'python2-decorator>=3.4.0'
+ 'python2-eventlet>=0.17.3'
+ 'python2-jinja>=2.6'
+ 'python2-keystonemiddleware-liberty'
+ 'python2-lxml>=2.3'
+ 'python2-routes>=1.12.3'
+ 'python2-webob>=1.2.3'
+ 'python2-greenlet>=0.3.2'
+ 'python2-paste-deploy>=1.5.0'
+ 'python2-paste'
+ 'python2-migrate-openstack'
+ 'python2-netaddr>=0.7.12'
+ 'python2-netifaces>=0.10.4'
+ 'python2-paramiko>=1.13.0'
+ 'python2-pyasn1'
+ 'python2-babel>=1.3'
+ 'python2-iso8601>=0.1.9'
+ 'python2-jsonschema>=2.0.0'
+ 'python2-jsonschema<3.0.0'
+ 'python2-cinderclient-liberty'
+ 'python2-keystoneclient-liberty'
+ 'python2-neutronclient-liberty'
+ 'python2-glanceclient-liberty'
+ 'python2-requests>=2.5.2'
+ 'python2-six>=1.9.0'
+ 'python2-stevedore-openstack'
+ 'python2-setuptools'
+ 'websockify>=0.6.0'
+ 'websockify<0.7'
+ 'python2-oslo-concurrency-liberty'
+ 'python2-oslo-config-liberty'
+ 'python2-oslo-context-liberty'
+ 'python2-oslo-log-liberty'
+ 'python2-oslo-serialization-liberty'
+ 'python2-oslo-utils-liberty'
+ 'python2-oslo-db-liberty'
+ 'python2-oslo-rootwrap-liberty'
+ 'python2-oslo-messaging-liberty'
+ 'python2-oslo-i18n-liberty'
+ 'python2-rfc3986>=0.2.0'
+ 'python2-oslo-middleware-liberty'
+ 'python2-psutil-liberty'
+ 'python2-oslo-versionedobjects-liberty'
+ 'python2-alembic>=0.7.2')
+makedepends=(python2-setuptools)
+source=("https://launchpad.net/nova/liberty/$osseries/+download/nova-$pkgver.tar.gz"
+ "nova-api.service"
+ "nova-cert.service"
+ "nova-conductor.service"
+ "nova-consoleauth.service"
+ "nova-novncproxy.service"
+ "nova-scheduler.service"
+ "nova_sudoers"
+ "nova-compute.conf"
+ "nova-compute.service")
+md5sums=('19e83fbb542cdcd4b464c3d2984e102e'
+ '5345f34af3bcc5b5b142bc1545821045'
+ '85d6229bd6336a074d6b9f284bab560d'
+ 'afff9d985f64b2d0403574f73fde7fdf'
+ '37d1fd1dd4724531d583a603a0185653'
+ '43d3516a9b1a53851bbcb0dcee0269d4'
+ '90d17720783c89a1d2d113e560bafab8'
+ 'b166058b5c25d0d7851adf30c2356691'
+ 'c15ecc2982a90c2a86c110833c6c4bbc'
+ 'e16fbaef08ba9fc08a726425d0c79429')
+
+build() {
+ cd nova-${pkgver}/
+ python2 setup.py build
+}
+
+package() {
+ cd nova-${pkgver}/
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+
+ install -d "${pkgdir}"/etc/
+ cp -r etc/ "${pkgdir}"/
+ install -d -m 0750 "${pkgdir}"/etc/sudoers.d/
+ cp ${srcdir}/nova_sudoers "${pkgdir}"/etc/sudoers.d/nova_sudoers
+ cp ${srcdir}/nova-compute.conf "${pkgdir}"/etc/nova/nova-compute.conf
+ install -d -m 0770 ${pkgdir}/var/lib/nova/
+ install -d -m 0770 ${pkgdir}/var/log/nova/
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/nova/LICENSE
+ install -D -m 644 ${srcdir}/nova-api.service ${pkgdir}/usr/lib/systemd/system/nova-api.service
+ install -D -m 644 ${srcdir}/nova-cert.service ${pkgdir}/usr/lib/systemd/system/nova-cert.service
+ install -D -m 644 ${srcdir}/nova-conductor.service ${pkgdir}/usr/lib/systemd/system/nova-conductor.service
+ install -D -m 644 ${srcdir}/nova-consoleauth.service ${pkgdir}/usr/lib/systemd/system/nova-consoleauth.service
+ install -D -m 644 ${srcdir}/nova-novncproxy.service ${pkgdir}/usr/lib/systemd/system/nova-novncproxy.service
+ install -D -m 644 ${srcdir}/nova-scheduler.service ${pkgdir}/usr/lib/systemd/system/nova-scheduler.service
+ install -D -m 644 ${srcdir}/nova-compute.service ${pkgdir}/usr/lib/systemd/system/nova-compute.service
+}
diff --git a/nova-api.service b/nova-api.service
new file mode 100644
index 000000000000..699f2a644621
--- /dev/null
+++ b/nova-api.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=Nova API server
+
+[Service]
+ExecStart=/usr/bin/nova-api --config-dir /etc/nova/
+User=root
+
+[Install]
+WantedBy=multi-user.target
diff --git a/nova-cert.service b/nova-cert.service
new file mode 100644
index 000000000000..3827d79fd7d1
--- /dev/null
+++ b/nova-cert.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=Nova Cert server
+
+[Service]
+ExecStart=/usr/bin/nova-cert --config-dir /etc/nova/
+User=root
+
+[Install]
+WantedBy=multi-user.target
diff --git a/nova-compute.conf b/nova-compute.conf
new file mode 100644
index 000000000000..323047d201a7
--- /dev/null
+++ b/nova-compute.conf
@@ -0,0 +1,7 @@
+[DEFAULT]
+libvirt_type=qemu
+libvirt_ovs_bridge=br-int
+libvirt_vif_type=ethernet
+libvirt_vif_driver=nova.virt.libvirt.vif.LibvirtHybridOVSBridgeDriver
+libvirt_use_virtio_for_bridges=True
+
diff --git a/nova-compute.service b/nova-compute.service
new file mode 100644
index 000000000000..f8f9d408996c
--- /dev/null
+++ b/nova-compute.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Nova Compute server
+
+[Service]
+ExecStart=/usr/bin/nova-compute --config-file /etc/nova/nova.conf --config-file /etc/nova/nova-compute.conf
+User=root
+
+[Install]
+WantedBy=multi-user.target
+
diff --git a/nova-conductor.service b/nova-conductor.service
new file mode 100644
index 000000000000..af56189f6ff3
--- /dev/null
+++ b/nova-conductor.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=Nova Conductor server
+
+[Service]
+ExecStart=/usr/bin/nova-conductor --config-dir /etc/nova/
+User=root
+
+[Install]
+WantedBy=multi-user.target
diff --git a/nova-consoleauth.service b/nova-consoleauth.service
new file mode 100644
index 000000000000..65395b1547ee
--- /dev/null
+++ b/nova-consoleauth.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=Nova ConsoleAuth server
+
+[Service]
+ExecStart=/usr/bin/nova-consoleauth --config-dir /etc/nova/
+User=root
+
+[Install]
+WantedBy=multi-user.target
diff --git a/nova-novncproxy.service b/nova-novncproxy.service
new file mode 100644
index 000000000000..970ce88826a2
--- /dev/null
+++ b/nova-novncproxy.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=Nova novncproxy server
+
+[Service]
+ExecStart=/usr/bin/nova-novncproxy --config-dir /etc/nova/
+User=root
+
+[Install]
+WantedBy=multi-user.target
diff --git a/nova-scheduler.service b/nova-scheduler.service
new file mode 100644
index 000000000000..299afa5126d1
--- /dev/null
+++ b/nova-scheduler.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=Nova Scheduler server
+
+[Service]
+ExecStart=/usr/bin/nova-scheduler --config-dir /etc/nova/
+User=root
+
+[Install]
+WantedBy=multi-user.target
diff --git a/nova.install b/nova.install
new file mode 100644
index 000000000000..dd83791a139e
--- /dev/null
+++ b/nova.install
@@ -0,0 +1,23 @@
+post_install() {
+ getent group nova &>/dev/null || groupadd nova >/dev/null
+ getent passwd nova &>/dev/null || useradd -d /var/lib/nova -g nova -s /bin/false nova >/dev/null
+
+ chmod 755 /etc/nova
+ chown -R nova:nova /etc/nova
+ chown root:root /etc/nova/rootwrap.conf
+ chown -R root:root /etc/nova/rootwrap.d
+ chown nova:nova /var/lib/nova
+ chown nova /var/log/nova
+ chown root:root /etc/sudoers.d/nova_sudoers
+ chmod 440 /etc/sudoers.d/nova_sudoers
+}
+
+post_upgrade() {
+ post_install
+}
+
+pre_remove() {
+ getent passwd nova &>/dev/null && userdel nova >/dev/null
+ getent group nova &>/dev/null && groupdel nova >/dev/null
+ true
+}
diff --git a/nova_sudoers b/nova_sudoers
new file mode 100644
index 000000000000..0f4362628777
--- /dev/null
+++ b/nova_sudoers
@@ -0,0 +1,3 @@
+Defaults:neutron !requiretty
+
+nova ALL = (root) NOPASSWD: /usr/bin/nova-rootwrap