summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD37
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ac09a6f37728
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = novnc
+ pkgdesc = javascript vnc client
+ pkgver = 0.5.1
+ pkgrel = 2
+ epoch = 1
+ url = https://github.com/kanaka/noVNC
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = bash
+ depends = python
+ source = https://github.com/kanaka/noVNC/archive/v0.5.1.tar.gz
+ md5sums = ac55b2316b2164b6e09ae3bd89c37cb6
+
+pkgname = novnc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f5ee3bd8d199
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+pkgname=novnc
+epoch=1
+pkgver=0.5.1
+pkgrel=2
+pkgdesc="javascript vnc client"
+arch=(i686 x86_64)
+url="https://github.com/kanaka/noVNC"
+license=('GPL')
+depends=('bash' 'python')
+source=("https://github.com/kanaka/noVNC/archive/v${pkgver}.tar.gz")
+md5sums=('ac55b2316b2164b6e09ae3bd89c37cb6')
+
+prepare() {
+ cd $srcdir/noVNC-${pkgver}
+ rm -f utils/*.o
+ rm -rf .git
+}
+
+build() {
+ cd $srcdir/noVNC-${pkgver}
+ make -C utils clean rebind.so
+}
+
+package() {
+ cd $srcdir/noVNC-${pkgver}
+ mkdir -p $pkgdir/usr/share/novnc $pkgdir/usr/share/doc/novnc $pkgdir/usr/bin
+ cp -a include utils images images/favicon.ico vnc.html vnc_auto.html \
+ $pkgdir/usr/share/novnc/
+ cp -a LICENSE.txt README.md $pkgdir/usr/share/doc/novnc
+ cat >$pkgdir/usr/bin/novnc <<EOF
+#!/bin/sh
+
+cd /usr/share/novnc || exit 1
+exec ./utils/launch.sh \$*
+EOF
+ chmod 0755 $pkgdir/usr/bin/novnc
+}