summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 25eaaf21a0f1..ac09a6f37728 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = novnc
pkgdesc = javascript vnc client
- pkgver = 0.5
+ pkgver = 0.5.1
pkgrel = 2
epoch = 1
url = https://github.com/kanaka/noVNC
arch = i686
arch = x86_64
license = GPL
- makedepends = git
depends = bash
depends = python
- source = novnc::git+https://github.com/kanaka/noVNC.git#tag=v0.5
- md5sums = SKIP
+ source = https://github.com/kanaka/noVNC/archive/v0.5.1.tar.gz
+ md5sums = ac55b2316b2164b6e09ae3bd89c37cb6
pkgname = novnc
diff --git a/PKGBUILD b/PKGBUILD
index 9f6587dce2a4..f5ee3bd8d199 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,28 @@
pkgname=novnc
epoch=1
-pkgver=0.5
+pkgver=0.5.1
pkgrel=2
pkgdesc="javascript vnc client"
arch=(i686 x86_64)
url="https://github.com/kanaka/noVNC"
license=('GPL')
depends=('bash' 'python')
-makedepends=('git')
-source=("$pkgname::git+https://github.com/kanaka/noVNC.git#tag=v0.5")
-md5sums=('SKIP')
+source=("https://github.com/kanaka/noVNC/archive/v${pkgver}.tar.gz")
+md5sums=('ac55b2316b2164b6e09ae3bd89c37cb6')
prepare() {
- cd $srcdir/novnc
+ cd $srcdir/noVNC-${pkgver}
rm -f utils/*.o
rm -rf .git
}
build() {
- cd $srcdir/novnc
+ cd $srcdir/noVNC-${pkgver}
make -C utils clean rebind.so
}
package() {
- cd $srcdir/novnc
+ cd $srcdir/noVNC-${pkgver}
mkdir -p $pkgdir/usr/share/novnc $pkgdir/usr/share/doc/novnc $pkgdir/usr/bin
cp -a include utils images images/favicon.ico vnc.html vnc_auto.html \
$pkgdir/usr/share/novnc/