summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD72
-rw-r--r--novnc@.service13
3 files changed, 66 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b23ad04cf22..4bcacf007f2a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,21 @@
-# Generated by makepkg 4.2.0
-# Sun Feb 22 00:02:56 UTC 2015
pkgbase = novnc-git
- pkgdesc = javascript vnc client
- pkgver = 20150218.65
+ pkgdesc = HTML VNC Client Library and Application
+ pkgver = 1.3.0.r28.g78eda3c
pkgrel = 1
- url = http://kanaka.github.com/noVNC/
- arch = i686
- arch = x86_64
- license = GPL
- optdepends = websockify: for vnc servers without websocket support
+ url = https://github.com/novnc/noVNC
+ arch = any
+ license = custom
+ makedepends = git
+ depends = bash
+ depends = websockify
+ depends = inetutils
+ depends = which
+ optdepends = python-numpy: better HyBi protocol performance
provides = novnc
conflicts = novnc
- source = novnc::git://github.com/kanaka/noVNC.git
- md5sums = SKIP
+ source = novnc::git+https://github.com/novnc/noVNC.git
+ source = novnc@.service
+ sha512sums = SKIP
+ sha512sums = 5dce6fb71dcdeab9ebe3986ebad431d01bb01860cb9960b1e70af84b2beba2330738cd9aa37ab9e025ee8263cba7475d484d5c6d55d4b3750d27aff37c7aef41
pkgname = novnc-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 2e2fe046148c..31579cbf1aa2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,50 @@
+# Maintainer: seiuneko <chfsefefgesfen foxmail>
+# Contributor: Radek Podgorny <radek@podgorny.cz>
+
pkgname=novnc-git
-pkgver=20150218.65
+pkgver=1.3.0.r28.g78eda3c
pkgrel=1
-pkgdesc="javascript vnc client"
-arch=(i686 x86_64)
-url="http://kanaka.github.com/noVNC/"
-license=('GPL')
-depends=()
+pkgdesc="HTML VNC Client Library and Application"
+arch=(any)
+url="https://github.com/novnc/noVNC"
+license=('custom')
+depends=('bash' 'websockify' 'inetutils' 'which')
+optdepends=('python-numpy: better HyBi protocol performance')
provides=('novnc')
conflicts=('novnc')
-source=("novnc::git://github.com/kanaka/noVNC.git")
-md5sums=('SKIP')
-optdepends=(
- 'websockify: for vnc servers without websocket support'
-)
+source=("novnc::git+https://github.com/novnc/noVNC.git"
+ "novnc@.service")
+sha512sums=('SKIP'
+ '5dce6fb71dcdeab9ebe3986ebad431d01bb01860cb9960b1e70af84b2beba2330738cd9aa37ab9e025ee8263cba7475d484d5c6d55d4b3750d27aff37c7aef41')
+makedepends=("git")
pkgver() {
- cd "$srcdir"/novnc
- echo "$(git log -1 --format="%cd" --date=short | sed 's|-||g').$(git rev-list --count master)"
-}
-
-prepare() {
- cd $srcdir/novnc
- rm -f utils/*.o
- rm -rf .git
+ cd "$srcdir"/novnc
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-build() {
- cd $srcdir/novnc
- #make -C utils
+prepare(){
+ cd "novnc"
+ sed \
+ -e 's#\(share\)#\1/webapps#g' \
+ -e '2 i WEBSOCKIFY=/usr/bin/websockify' \
+ -i utils/novnc_proxy
}
package() {
- cd $srcdir/novnc
- mkdir -p $pkgdir/usr/share/novnc $pkgdir/usr/share/doc/novnc $pkgdir/usr/bin
- cp -a include utils images images/favicon.ico vnc.html vnc_auto.html \
- $pkgdir/usr/share/novnc/
- cp -a LICENSE.txt README.md $pkgdir/usr/share/doc/novnc
- cat >$pkgdir/usr/bin/novnc <<EOF
-#!/bin/sh
-
-cd /usr/share/novnc || exit 1
-exec ./utils/launch.sh \$*
-EOF
- chmod 0755 $pkgdir/usr/bin/novnc
+ install -Dm644 novnc@.service "${pkgdir}/usr/lib/systemd/system/novnc@.service"
+
+ cd "novnc"
+
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 vendor/pako/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE.MIT"
+ ( cd docs; find . -name 'LICENSE*' -type f -exec cp -a {} "$pkgdir/usr/share/licenses/$pkgname/{}" \; )
+
+ install -dm644 "$pkgdir/usr/share/doc/$pkgname"
+ ( cd docs; find . ! -name 'LICENSE*' -type f -exec cp -a {} "$pkgdir/usr/share/doc/$pkgname/{}" \; )
+
+ install -Dm755 utils/novnc_proxy "$pkgdir/usr/bin/novnc"
+
+ install -dm755 "$pkgdir/usr/share/webapps/novnc"
+ cp -a app core po vendor vnc.html karma.conf.js package.json vnc_lite.html "$pkgdir/usr/share/webapps/novnc"
}
diff --git a/novnc@.service b/novnc@.service
new file mode 100644
index 000000000000..039d7a886331
--- /dev/null
+++ b/novnc@.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=noVNC Service
+After=network.target
+
+[Service]
+Type=idle
+DynamicUser=yes
+Restart=on-failure
+RestartSec=5s
+ExecStart=/usr/bin/novnc --vnc %i
+
+[Install]
+WantedBy=multi-user.target \ No newline at end of file