summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD46
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3b23ad04cf22
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by makepkg 4.2.0
+# Sun Feb 22 00:02:56 UTC 2015
+pkgbase = novnc-git
+ pkgdesc = javascript vnc client
+ pkgver = 20150218.65
+ pkgrel = 1
+ url = http://kanaka.github.com/noVNC/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ optdepends = websockify: for vnc servers without websocket support
+ provides = novnc
+ conflicts = novnc
+ source = novnc::git://github.com/kanaka/noVNC.git
+ md5sums = SKIP
+
+pkgname = novnc-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e2fe046148c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+pkgname=novnc-git
+pkgver=20150218.65
+pkgrel=1
+pkgdesc="javascript vnc client"
+arch=(i686 x86_64)
+url="http://kanaka.github.com/noVNC/"
+license=('GPL')
+depends=()
+provides=('novnc')
+conflicts=('novnc')
+source=("novnc::git://github.com/kanaka/noVNC.git")
+md5sums=('SKIP')
+optdepends=(
+ 'websockify: for vnc servers without websocket support'
+)
+
+pkgver() {
+ cd "$srcdir"/novnc
+ echo "$(git log -1 --format="%cd" --date=short | sed 's|-||g').$(git rev-list --count master)"
+}
+
+prepare() {
+ cd $srcdir/novnc
+ rm -f utils/*.o
+ rm -rf .git
+}
+
+build() {
+ cd $srcdir/novnc
+ #make -C utils
+}
+
+package() {
+ cd $srcdir/novnc
+ mkdir -p $pkgdir/usr/share/novnc $pkgdir/usr/share/doc/novnc $pkgdir/usr/bin
+ cp -a include utils images images/favicon.ico vnc.html vnc_auto.html \
+ $pkgdir/usr/share/novnc/
+ cp -a LICENSE.txt README.md $pkgdir/usr/share/doc/novnc
+ cat >$pkgdir/usr/bin/novnc <<EOF
+#!/bin/sh
+
+cd /usr/share/novnc || exit 1
+exec ./utils/launch.sh \$*
+EOF
+ chmod 0755 $pkgdir/usr/bin/novnc
+}