summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
-rw-r--r--npd6.install4
-rw-r--r--npd6.service8
4 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..776610c85cca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = npd6
+ pkgdesc = A Linux daemon to provide a proxy service for IPv6 Neighbor Solcitations received by a gateway routing device.
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://github.com/npd6/npd6/
+ install = npd6.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ source = https://github.com/npd6/npd6/archive/1.1.0.tar.gz
+ source = npd6.service
+ md5sums = 75f09177c52b86ee82260bb6b1c726a5
+ md5sums = 319cc4f814a322e6aa9032c4d0f41dc6
+
+pkgname = npd6
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..14f020a4ccf6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Contributor: Justin Wong <justin.w.xd(at)gmail(dot)com>
+pkgname=npd6
+pkgver=1.1.0
+pkgrel=1
+pkgdesc='A Linux daemon to provide a proxy service for IPv6 Neighbor Solcitations received by a gateway routing device.'
+arch=('i686' 'x86_64')
+license=('GPL3')
+url='https://github.com/npd6/npd6/'
+source=("https://github.com/npd6/npd6/archive/${pkgver}.tar.gz"
+ "npd6.service")
+install=npd6.install
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make || return 1
+}
+
+package() {
+ cd ${srcdir}
+ install -D -m 644 npd6.service ${pkgdir}/usr/lib/systemd/system/npd6.service
+
+ cd ${pkgname}-${pkgver}
+ install -D -m 755 npd6 ${pkgdir}/usr/bin/npd6
+ install -D -m 644 etc/npd6.conf.sample ${pkgdir}/etc/npd6.conf.sample
+ install -D -m 644 man/npd6.conf.5.gz ${pkgdir}/usr/share/man5/npd6.conf.5.gz
+ install -D -m 644 man/npd6.8.gz ${pkgdir}/usr/share/man8/npd6.8.gz
+}
+md5sums=('75f09177c52b86ee82260bb6b1c726a5'
+ '319cc4f814a322e6aa9032c4d0f41dc6')
diff --git a/npd6.install b/npd6.install
new file mode 100644
index 000000000000..8bb213d31154
--- /dev/null
+++ b/npd6.install
@@ -0,0 +1,4 @@
+post_install() {
+ echo "Sample Configuration file has been installed as /etc/npd6.conf.sample"
+ echo "Edit it and save to /etc/npd6.conf"
+}
diff --git a/npd6.service b/npd6.service
new file mode 100644
index 000000000000..de4d0613dc69
--- /dev/null
+++ b/npd6.service
@@ -0,0 +1,8 @@
+[Unit]
+Description=Neighbor Proxy Daemon IPv6
+
+[Service]
+ExecStart=/usr/bin/npd6 -f
+
+[Install]
+WantedBy=multi-user.target