summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD19
3 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fe91c9525958
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = nsis-untgz-bin
+ pkgdesc = NSIS plugin that allows to extract the files from a tarball
+ pkgver = 1.0.18
+ pkgrel = 1
+ url = https://nsis.sourceforge.io/UnTGZ_plug-in
+ arch = any
+ license = custom
+ depends = nsis
+ source = Untgz-1.0.18.zip::https://nsis.sourceforge.io/mediawiki/images/9/9d/Untgz.zip
+ sha256sums = 3c2a088b82b27b6183ea6479d61a6c0ecc54f52e484577b641ca21867bd81a4b
+
+pkgname = nsis-untgz-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5616c846f655
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Roboron <robertoms258 at gmail dot com>
+
+pkgname=nsis-untgz-bin
+pkgver=1.0.18
+pkgrel=1
+pkgdesc="NSIS plugin that allows to extract the files from a tarball"
+arch=('any') # Does not contain any code that's executed on the host system
+url="https://nsis.sourceforge.io/UnTGZ_plug-in"
+license=('custom')
+depends=('nsis')
+source=("Untgz-$pkgver.zip::https://nsis.sourceforge.io/mediawiki/images/9/9d/Untgz.zip")
+sha256sums=('3c2a088b82b27b6183ea6479d61a6c0ecc54f52e484577b641ca21867bd81a4b')
+
+
+package() {
+ install -D "$srcdir"/untgz/untgz.dll "$pkgdir"/usr/share/nsis/Plugins/x86-ansi/untgz.dll
+ install -D "$srcdir"/untgz/unicode/untgz.dll "$pkgdir"/usr/share/nsis/Plugins/x86-unicode/untgz.dll
+ install -D "$srcdir"/untgz/LICENSE.TXT "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
+}