summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a0e92e86d3f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = nsnake
+ pkgdesc = Customizable Snake game with ncurses for the terminal
+ pkgver = 3.0.1
+ pkgrel = 2
+ url = http://nsnake.alexdantas.net/
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ depends = ncurses
+ source = https://github.com/alexdantas/nsnake/archive/v3.0.1.tar.gz
+ md5sums = bb024bdf8f95989b38c4893a99228d34
+
+pkgname = nsnake
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1ee29de82b2f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: megadriver <megadriver at gmx dot com>
+# Contributor: Lucas de Sena <lucas DOT ta23 @ gmail DOT com>
+# Contributor: Alexandre Dantas <eu @ alexdantas DOT net>
+
+pkgname=nsnake
+pkgver=3.0.1
+pkgrel=2
+pkgdesc="Customizable Snake game with ncurses for the terminal"
+arch=('x86_64' 'i686')
+url="http://nsnake.alexdantas.net/"
+license=('GPL3')
+depends=('ncurses')
+source=(https://github.com/alexdantas/$pkgname/archive/v$pkgver.tar.gz)
+md5sums=('bb024bdf8f95989b38c4893a99228d34')
+
+build() {
+ cd "$srcdir/nSnake-$pkgver"
+
+ make
+}
+
+package() {
+ cd "$srcdir/nSnake-$pkgver"
+
+ make DESTDIR="$pkgdir" PREFIX="/usr" install
+}
+