summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--LICENSE27
-rw-r--r--PKGBUILD45
3 files changed, 77 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5262df799631..168759a460ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,25 @@
# Generated by mksrcinfo v8
-# Wed Mar 22 20:53:17 UTC 2017
+# Wed Mar 29 20:14:52 UTC 2017
pkgbase = nteract-bin
pkgdesc = Interactive literate coding notebook
- pkgver = 0.0.13
+ pkgver = 0.1.0
pkgrel = 1
url = https://nteract.io
arch = x86_64
license = BSD-3-Clause
- source_x86_64 = https://github.com/nteract/nteract/releases/download/v0.0.13/nteract-linux-x64.tar.gz
- md5sums_x86_64 = c7389edaa93aa178ddd4bb025937bb25
+ makedepends = gendesk
+ depends = alsa-lib
+ depends = gconf
+ depends = gtk2
+ depends = libxss
+ depends = libxtst
+ depends = nodejs
+ depends = nss
+ depends = python
+ source = nteract_0.1.0_amd64.deb::https://github.com/nteract/nteract/releases/download/v0.1.0/nteract_0.1.0_amd64.deb
+ source = LICENSE
+ sha256sums = 38d56954443a1debad628d1d76750e9c20f32932bfcb6eb632651211c3f6e1b2
+ sha256sums = 9810f3d57c552d3b3f6c82cb3b6f3402d6faf94fc5a63067fe28360fb3b8b688
pkgname = nteract-bin
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..1064cce07305
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,27 @@
+Copyright (c) 2016, nteract contributors
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+
+* Redistributions of source code must retain the above copyright notice, this
+ list of conditions and the following disclaimer.
+
+* Redistributions in binary form must reproduce the above copyright notice,
+ this list of conditions and the following disclaimer in the documentation
+ and/or other materials provided with the distribution.
+
+* Neither the name of transformime-react nor the names of its
+ contributors may be used to endorse or promote products derived from
+ this software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
+AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE
+FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
+CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
+OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
index 9fa8eae7581c..4fe9a19cc86b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,47 @@
-# Original Author: chendaniely<chendaniely@gmail.com>
+# Maintainer: chendaniely <chendaniely@gmail.com>
+# Contributor: Conor Anderson <conor@conr.ca>
pkgname=nteract-bin
-pkgver=0.0.13
+_pkgname=${pkgname%-bin}
+pkgver=0.1.0
pkgrel=1
pkgdesc="Interactive literate coding notebook"
url='https://nteract.io'
arch=('x86_64')
-depends=('')
+depends=('alsa-lib' 'gconf' 'gtk2' 'libxss' 'libxtst' 'nodejs' 'nss' 'python')
+makedepends=('gendesk')
license=('BSD-3-Clause')
-md5sums_x86_64=('c7389edaa93aa178ddd4bb025937bb25')
-source_x86_64=("https://github.com/nteract/nteract/releases/download/v$pkgver/nteract-linux-x64.tar.gz")
+source=("${_pkgname}_${pkgver}_amd64.deb::https://github.com/nteract/nteract/releases/download/v$pkgver/nteract_0.1.0_amd64.deb"
+ "LICENSE")
+sha256sums=('38d56954443a1debad628d1d76750e9c20f32932bfcb6eb632651211c3f6e1b2'
+ '9810f3d57c552d3b3f6c82cb3b6f3402d6faf94fc5a63067fe28360fb3b8b688')
-build() {
- cd "${srcdir}"
- bsdtar -xf nteract-linux-x64.tar.gz
+prepare() {
+ gendesk -f -n --name="${_pkgname}" --pkgname="${_pkgname}" --pkgdesc="${pkgdesc}" --exec="${_pkgname}" --categories="Development"
}
package() {
- mv $srcdir/ $pkgdir/opt
- rm $pkgdir/opt/nteract-linux-x64.tar.gz
+ cd "$srcdir"
+ ar xf "${_pkgname}_${pkgver}_amd64.deb"
+ tar xf data.tar.xz
+
+ # Place files
+ install -d "${pkgdir}/usr/lib/${_pkgname}"
+ cp -a "${srcdir}/opt/${_pkgname}/"* "${pkgdir}/usr/lib/${_pkgname}"
+
+ # Symlink main binary
+ install -d "${pkgdir}/usr/bin"
+ ln -s "/usr/lib/${_pkgname}/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+
+ # Place desktop entry and icons
+ desktop-file-install -m 644 --dir "${pkgdir}/usr/share/applications/" "${srcdir}/${_pkgname}.desktop"
+ install -dm755 "${pkgdir}/usr/share/icons/hicolor/"
+ cp -R "${srcdir}/usr/share/icons/hicolor/"* "${pkgdir}/usr/share/icons/hicolor/"
+
+ # Place license files
+ for license in "LICENSE.electron.txt" "LICENSES.chromium.html"; do
+ install -Dm644 "${pkgdir}/usr/lib/${_pkgname}/${license}" "${pkgdir}/usr/share/licenses/${_pkgname}/${license}"
+ rm "${pkgdir}/usr/lib/${_pkgname}/${license}"
+ done
+ install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
}