summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD9
-rw-r--r--nteract-bin.install9
4 files changed, 27 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 168759a460ff..74b8633db73c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,9 @@
-# Generated by mksrcinfo v8
-# Wed Mar 29 20:14:52 UTC 2017
pkgbase = nteract-bin
pkgdesc = Interactive literate coding notebook
pkgver = 0.1.0
pkgrel = 1
url = https://nteract.io
+ install = nteract-bin.install
arch = x86_64
license = BSD-3-Clause
makedepends = gendesk
@@ -16,6 +15,12 @@ pkgbase = nteract-bin
depends = nodejs
depends = nss
depends = python
+ optdepends = ihaskell-git: support for Haskell
+ optdepends = julia: support for Julia (requires the "IJulia" package)
+ optdepends = python-ipykernel: support for Python 3
+ optdepends = python2-ipykernel: support for Python 2
+ optdepends = r: support for R (requires the "IRkernel" package)
+ optdepends = sagemath-jupyter: support for SageMath
source = nteract_0.1.0_amd64.deb::https://github.com/nteract/nteract/releases/download/v0.1.0/nteract_0.1.0_amd64.deb
source = LICENSE
sha256sums = 38d56954443a1debad628d1d76750e9c20f32932bfcb6eb632651211c3f6e1b2
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..829043b617f2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/*
+src/*
+nteract_*_amd64.deb
diff --git a/PKGBUILD b/PKGBUILD
index 4fe9a19cc86b..6b736230f8b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,9 +8,16 @@ pkgrel=1
pkgdesc="Interactive literate coding notebook"
url='https://nteract.io'
arch=('x86_64')
+license=('BSD-3-Clause')
depends=('alsa-lib' 'gconf' 'gtk2' 'libxss' 'libxtst' 'nodejs' 'nss' 'python')
makedepends=('gendesk')
-license=('BSD-3-Clause')
+optdepends=('ihaskell-git: support for Haskell'
+ 'julia: support for Julia (requires the "IJulia" package)'
+ 'python-ipykernel: support for Python 3'
+ 'python2-ipykernel: support for Python 2'
+ 'r: support for R (requires the "IRkernel" package)'
+ 'sagemath-jupyter: support for SageMath')
+install=$pkgname.install
source=("${_pkgname}_${pkgver}_amd64.deb::https://github.com/nteract/nteract/releases/download/v$pkgver/nteract_0.1.0_amd64.deb"
"LICENSE")
sha256sums=('38d56954443a1debad628d1d76750e9c20f32932bfcb6eb632651211c3f6e1b2'
diff --git a/nteract-bin.install b/nteract-bin.install
new file mode 100644
index 000000000000..d2599f4edbd7
--- /dev/null
+++ b/nteract-bin.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo "==> If you require help installing additional kernels, please visit:"
+ echo "==> https://wiki.archlinux.org/index.php/Jupyter#Kernels"
+}
+
+post_upgrade() {
+ post_install()
+}
+