summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--Makefile.patch4
-rw-r--r--PKGBUILD48
-rw-r--r--dkms.conf3
4 files changed, 23 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 802d111863b1..b249901e24db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,9 +13,11 @@ pkgbase = ntfs3-dkms-git
conflicts = ntfs3
options = !strip
options = !emptydirs
+ source = git+https://github.com/Paragon-Software-Group/linux-ntfs3
source = dkms.conf
source = Makefile.patch
- sha256sums = ad5b987db08716b67888dee326658087efe22da5a64fb9cdaaec2c4b57817362
- sha256sums = fd4cf0e2dc160efecc55d4ea99667669b870599e4e81be435ec2201381b7e2ac
+ sha256sums = SKIP
+ sha256sums = 1f44f85635ecfb08f8d99fcd8a4e2e7991865fc7d1431ea1e5af69a2a5fec4e3
+ sha256sums = 89f89a217af207091534ffe14db2634604809397f1a65420ce6048e7d87e834f
pkgname = ntfs3-dkms-git
diff --git a/Makefile.patch b/Makefile.patch
index 929ee32e3419..214dd666b751 100644
--- a/Makefile.patch
+++ b/Makefile.patch
@@ -1,5 +1,5 @@
---- Makefile
-+++ Makefile
+--- fs/ntfs3/Makefile
++++ fs/ntfs3/Makefile
@@ -33,4 +33,13 @@
decompress_common.o \
lzx_decompress.o \
diff --git a/PKGBUILD b/PKGBUILD
index b4ea931ba00b..441cb26e7c6c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,8 @@ pkgrel=1
epoch=1
pkgdesc="NTFS3 is fully functional NTFS Read-Write driver. The driver works with NTFS versions up to 3.1."
arch=('any')
-url="https://github.com/Paragon-Software-Group/linux-ntfs3"
+_repo='linux-ntfs3'
+url="https://github.com/Paragon-Software-Group/${_repo}"
license=('GPL2')
depends=('dkms')
makedepends=('git')
@@ -13,49 +14,32 @@ conflicts=('ntfs3')
options=('!strip' '!emptydirs')
source=(
+ "git+${url}"
"dkms.conf"
"Makefile.patch"
)
sha256sums=(
- 'ad5b987db08716b67888dee326658087efe22da5a64fb9cdaaec2c4b57817362'
- 'fd4cf0e2dc160efecc55d4ea99667669b870599e4e81be435ec2201381b7e2ac'
+ 'SKIP'
+ '1f44f85635ecfb08f8d99fcd8a4e2e7991865fc7d1431ea1e5af69a2a5fec4e3'
+ '89f89a217af207091534ffe14db2634604809397f1a65420ce6048e7d87e834f'
)
-_ver="6.5"
-_since="1688329290"
-
-# The whole kernel history is very huge, so downloading it is a pain.
-# Also commits count is insane and we don't want to see all that in pkgver.
-# Here is a tricky workaround.
-# Make a shallow clone since the specified timestamp.
-
pkgver() {
- cd "repo"
-
- local rev sha
- rev=$(("$(git rev-list --count HEAD)" - 1))
- sha="$(git rev-parse HEAD)"
-
- echo "${_ver}.r${rev}.g${sha:0:7}"
+ cd "${_repo}"
+ git describe --long --tags --abbrev=7 | sed 's/^ntfs3_for_//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- if [ ! -d "repo" ]; then
- git clone --shallow-since="${_since}" --filter=tree:0 --no-checkout --single-branch "${url}" "repo"
- fi
-
- cd "repo"
- git fetch -f
- git sparse-checkout set --no-cone "/fs/ntfs3"
- git reset --hard FETCH_HEAD
-
- cd "fs/ntfs3"
- patch -i "${srcdir}/Makefile.patch"
+ cd "${_repo}"
+ patch -p0 -i "${srcdir}/Makefile.patch"
}
package() {
- local dest="${pkgdir}/usr/src/ntfs3-${_ver}"
- install -Dm644 -t "${dest}" "${source[0]}"
- cp -rpT "repo/fs/ntfs3" "${dest}"
+ local dest="${pkgdir}/usr/src/ntfs3-${pkgver}"
+ install -Dm644 -t "${dest}" "dkms.conf"
+ sed -i "s/@PKGVER@/${pkgver}/" "${dest}/dkms.conf"
+
+ cd "${_repo}"
+ cp -rpT "fs/ntfs3" "${dest}"
}
diff --git a/dkms.conf b/dkms.conf
index e12dcd836b54..989ddfbdee25 100644
--- a/dkms.conf
+++ b/dkms.conf
@@ -1,7 +1,6 @@
PACKAGE_NAME="ntfs3"
-PACKAGE_VERSION="6.5"
+PACKAGE_VERSION="@PKGVER@"
BUILT_MODULE_NAME[0]="ntfs3"
DEST_MODULE_LOCATION[0]="/kernel/fs/ntfs3"
AUTOINSTALL="yes"
MAKE[0]="KVERSION=${kernelver} CONFIG_NTFS3_FS=m CONFIG_NTFS3_LZX_XPRESS=y CONFIG_NTFS3_FS_POSIX_ACL=y make KDIR=${kernel_source_dir}"
-BUILD_EXCLUSIVE_KERNEL="^6\.[4-5]\.?"