summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..78a1eff1a512
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = nuitka-git
+ pkgdesc = A Python compiler
+ pkgver = 0.5.28.1.r1.g4d1a1741
+ pkgrel = 1
+ url = https://nuitka.net/
+ arch = any
+ license = apache
+ makedepends = git
+ depends = python
+ optdepends = chrpath: for building standalone executables
+ provides = nuitka
+ conflicts = nuitka
+ options = !emptydirs
+ source = git+https://git.nuitka.net/Nuitka.git
+ sha256sums = SKIP
+
+pkgname = nuitka-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9daf2d500ec6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=nuitka-git
+pkgver=0.5.28.1.r1.g4d1a1741
+pkgrel=1
+pkgdesc="A Python compiler"
+arch=('any')
+url="https://nuitka.net/"
+license=('apache')
+depends=('python')
+makedepends=('git')
+optdepends=('chrpath: for building standalone executables')
+provides=('nuitka')
+conflicts=('nuitka')
+options=('!emptydirs')
+source=("git+https://git.nuitka.net/Nuitka.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "Nuitka"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "Nuitka"
+
+ python "setup.py" install --root="$pkgdir" --optimize=1
+}