summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--MKPKG6
-rw-r--r--PKGBUILD32
-rw-r--r--numix-icon-theme.install14
4 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..385261021daf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = numix-icon-theme-git
+ pkgdesc = Base icon theme from the Numix project
+ pkgver = 0.r317.290d12e
+ pkgrel = 1
+ url = http://numixproject.org/
+ install = numix-icon-theme.install
+ arch = any
+ license = GPL3
+ makedepends = git
+ provides = numix-icon-theme
+ provides = numix-light-icon-theme
+ conflicts = numix-icon-theme
+ conflicts = numix-light-icon-theme
+ options = !strip
+ source = git+https://github.com/numixproject/numix-icon-theme.git
+ sha256sums = SKIP
+
+pkgname = numix-icon-theme-git
+
diff --git a/MKPKG b/MKPKG
new file mode 100644
index 000000000000..55709b418b6a
--- /dev/null
+++ b/MKPKG
@@ -0,0 +1,6 @@
+arch=('any')
+pkgname=('numix-icon-theme-git')
+
+check_git $packagedir/$pkgname/${pkgname%-*}
+
+# vim: ts=2 sw=2 et:
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e69e4abc9c55
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Diego <cdprincipe@gmail.com>
+
+pkgname=numix-icon-theme-git
+pkgver=0.r317.290d12e
+pkgrel=1
+pkgdesc='Base icon theme from the Numix project'
+arch=('any')
+url='http://numixproject.org/'
+license=('GPL3')
+makedepends=('git')
+provides=('numix-icon-theme' 'numix-light-icon-theme')
+conflicts=('numix-icon-theme' 'numix-light-icon-theme')
+options=('!strip')
+install='numix-icon-theme.install'
+source=('git+https://github.com/numixproject/numix-icon-theme.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd numix-icon-theme
+
+ printf "0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd numix-icon-theme
+
+ install -dm 755 "$pkgdir"/usr/share/icons
+ cp -dr --no-preserve='ownership' Numix{,-Light} "$pkgdir"/usr/share/icons/
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/numix-icon-theme.install b/numix-icon-theme.install
new file mode 100644
index 000000000000..567c6db0b5a5
--- /dev/null
+++ b/numix-icon-theme.install
@@ -0,0 +1,14 @@
+post-install() {
+ gtk-update-icon-cache -ftq usr/share/icons/Numix
+ gtk-update-icon-cache -ftq usr/share/icons/Numix-Light
+}
+
+post-upgrade() {
+ post-install
+}
+
+post-remove() {
+ post-install
+}
+
+# vim: ts=2 sw=2 et: