summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore10
-rw-r--r--PKGBUILD19
3 files changed, 18 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 968ab12d628e..201d0124e0b9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
pkgbase = nuovext-icon-theme
pkgdesc = nuoveXT2 icon theme
- pkgver = 0.1.0
- pkgrel = 2
+ pkgver = 0.1.1
+ pkgrel = 1
url = https://github.com/redtide/icon-theme-nuovext
install = nuovext-icon-theme.install
arch = any
- license = GPL
- makedepends = git
+ license = LGPL3
depends = gtk-update-icon-cache
- source = git://github.com/redtide/icon-theme-nuovext.git
+ source = icon-theme-nuovext-0.1.1.tar.gz::https://github.com/redtide/icon-theme-nuovext/archive/refs/tags/0.1.1.tar.gz
md5sums = SKIP
pkgname = nuovext-icon-theme
-
diff --git a/.gitignore b/.gitignore
index cfa70be2e9e1..0dfe2d3940c9 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,5 @@
-/icon-theme-nuovext
-/nuovext-icon-theme
-/pkg
-/src
-*.tar*
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!nuovext-icon-theme.install
diff --git a/PKGBUILD b/PKGBUILD
index 9885ead43513..60fa20532b68 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,26 @@
-# Maintainer: RedTide
+# Maintainer: redtide <redtid3@gmail.com>
+_pkgname=icon-theme-nuovext
pkgname=nuovext-icon-theme
-reponame=icon-theme-nuovext
-pkgver=0.1.0
-pkgrel=2
+pkgver=0.1.1
+pkgrel=1
pkgdesc="nuoveXT2 icon theme"
arch=('any')
-url="https://github.com/redtide/$reponame"
-license=('GPL')
+url="https://github.com/redtide/$_pkgname"
+license=('LGPL3')
depends=('gtk-update-icon-cache')
-makedepends=('git')
install=nuovext-icon-theme.install
-source=(git://github.com/redtide/$reponame.git)
+source=("$_pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz")
md5sums=('SKIP')
build() {
- cd $reponame
+ cd "$_pkgname-$pkgver"
./autogen.sh
./configure --prefix=/usr
make
}
package() {
- cd $reponame
+ cd "$_pkgname-$pkgver"
make DESTDIR="$pkgdir" install
}