summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD7
-rw-r--r--nushell.install12
3 files changed, 22 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0cff315b8a01..003bba4b66bb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = nushell-git
pkgdesc = A new type of shell
- pkgver = 0.76.0.r124.g7e82f8d
+ pkgver = 0.76.0.r134.gc7583ec
pkgrel = 1
url = https://www.nushell.sh
+ install = nushell.install
arch = x86_64
arch = i686
arch = armv6h
@@ -11,11 +12,12 @@ pkgbase = nushell-git
makedepends = git
makedepends = cargo
depends = openssl
- depends = zlib
+ depends = libxcb
depends = curl
- optdepends = libxcb
- provides = nushell=0.76.0.r124.g7e82f8d
+ depends = bzip2
+ provides = nushell=0.76.0.r134.gc7583ec
conflicts = nushell
+ options = !lto
source = nushell::git+https://github.com/nushell/nushell.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 3150fafd1904..4a5a46a34711 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,18 +10,19 @@ BUILDENV+=(!check)
_pkgname=nushell
pkgname=$_pkgname-git
-pkgver=0.76.0.r124.g7e82f8d
+pkgver=0.76.0.r134.gc7583ec
pkgrel=1
pkgdesc='A new type of shell'
arch=('x86_64' 'i686' 'armv6h' 'armv7h')
url='https://www.nushell.sh'
_url="https://github.com/$_pkgname/$_pkgname"
license=('MIT')
-depends=('openssl' 'zlib' 'curl')
-optdepends=('libxcb')
+depends=('openssl' 'libxcb' 'curl' 'bzip2')
makedepends=('git' 'cargo')
conflicts=("$_pkgname")
provides=("$_pkgname=$pkgver")
+options=('!lto')
+install=nushell.install
source=("${pkgname%-git}::git+$_url.git")
sha256sums=('SKIP')
diff --git a/nushell.install b/nushell.install
new file mode 100644
index 000000000000..f39a630bace0
--- /dev/null
+++ b/nushell.install
@@ -0,0 +1,12 @@
+post_install() {
+ grep -Fqx /bin/nu /etc/shells || echo /bin/nu >> /etc/shells
+ grep -Fqx /usr/bin/nu /etc/shells || echo /usr/bin/nu >> /etc/shells
+}
+
+post_upgrade() {
+ post_install
+}
+
+pre_remove() {
+ sed -i -r '/^(\/usr)?\/bin\/nu$/d' etc/shells
+}