summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD29
-rw-r--r--nuvexport.install16
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6431908a363f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = nuvexport
+ pkgdesc = Export MythTV .nuv and .mpeg files to other formats
+ pkgver = 0.5
+ pkgrel = 3
+ epoch = 2
+ url = http://www.mythtv.org/wiki/Nuvexport
+ install = nuvexport.install
+ arch = any
+ license = GPL
+ depends = ffmpeg
+ depends = id3lib
+ depends = mplayer
+ depends = mythtv
+ depends = perl-date-manip
+ depends = perl-dbd-mysql
+ depends = transcode
+ backup = etc/nuvexportrc
+ source = http://forevermore.net/files/nuvexport/nuvexport-0.5-0.20100817.svn.tar.bz2
+ sha256sums = b8138e31786031293dd3cee2dd6554b187b74723836732b8fc727b67a5262995
+
+pkgname = nuvexport
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..401d38a166e2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# $Id: PKGBUILD 113900 2014-07-01 08:10:11Z fyan $
+# Maintainer: Jonathan Conder <jonno.conder@gmail.com>
+# Contributor: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: Paul Mattal <paul@archlinux.org>
+# Contributor: Paul Mattal <paul@mattal.com>
+# Contributor: Jeremy Sands <cto@jeremysands.com>
+# Contributor: Alexander Rødseth <rodseth@gmail.com>
+
+pkgname=nuvexport
+pkgver=0.5
+pkgrel=3
+epoch=2
+pkgdesc="Export MythTV .nuv and .mpeg files to other formats"
+arch=('any')
+url="http://www.mythtv.org/wiki/Nuvexport"
+license=('GPL')
+depends=('ffmpeg' 'id3lib' 'mplayer' 'mythtv' 'perl-date-manip' 'perl-dbd-mysql'
+ 'transcode')
+backup=('etc/nuvexportrc')
+install=$pkgname.install
+source=("http://forevermore.net/files/$pkgname/$pkgname-$pkgver-0.20100817.svn.tar.bz2")
+sha256sums=('b8138e31786031293dd3cee2dd6554b187b74723836732b8fc727b67a5262995')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make INSTALL=/bin/install prefix="$pkgdir/usr" sysconfdir="$pkgdir/etc" install
+ sed -i "s:/tmp/fifodir:/var/tmp/fifodir:g" "$pkgdir/usr/share/nuvexport/export"/*.pm
+}
diff --git a/nuvexport.install b/nuvexport.install
new file mode 100644
index 000000000000..89be25914dbc
--- /dev/null
+++ b/nuvexport.install
@@ -0,0 +1,16 @@
+post_install() {
+ cat << _EOF
+
+==> IMPORTANT!!!
+==> To use nuvexport, you will need to copy ~/.mythtv/config.xml
+==> from a working MythTV installation to /usr/lib/mythtv/config.xml
+==>
+==> You can also run nuvexport --transcode and get potentially better
+==> results.
+
+_EOF
+}
+
+post_upgrade() {
+ post_install $1
+}