summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD52
-rw-r--r--fix-404.patch12
-rw-r--r--fix-wx-issues.patch32
-rw-r--r--nuxhash-gui.desktop10
-rwxr-xr-xnuxhash-gui.sh3
-rwxr-xr-xnuxhashd.sh3
7 files changed, 140 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1d1d4f38e6f4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = nuxhash-venv-git
+ pkgdesc = A NiceHash cryptocurrency mining client for Linux - Python 3.9 venv, fixes GUI problems.
+ pkgver = v1.0.0b2.r33.g33e9a09
+ pkgrel = 1
+ url = https://github.com/YoRyan/nuxhash
+ arch = x86_64
+ license = GPL3
+ depends = python39
+ depends = curl
+ depends = nvidia
+ depends = opencl-nvidia
+ depends = cuda
+ provides = nuxhash-git
+ conflicts = nuxhash-git
+ source = git+https://github.com/YoRyan/nuxhash.git
+ source = fix-wx-issues.patch
+ source = fix-404.patch
+ source = nuxhashd.sh
+ source = nuxhash-gui.sh
+ source = nuxhash-gui.desktop
+ sha256sums = SKIP
+ sha256sums = 79c56a0fcc373cc76d5b627514103cb4914f7a45780f131ac4a81946b0371bbd
+ sha256sums = 55d410a61aa080e0680091fbf3dd3e54837c11b60c13257d2c7e6b75395b20c6
+ sha256sums = c6bc0d3c707091469ce2a91e906131a3b799afa46451ff21547b780cfac4cd0c
+ sha256sums = 62d2c21495b5b0e3ff9354b585adc75816752ab2d9a5cc3e9af89ed77ed7e1c1
+ sha256sums = 779c28c990c97b6c6fb2b2ad1cf84ff99dcdf5c1b72f034750994fdc8a645055
+
+pkgname = nuxhash-venv-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..828dac6c51ea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Ben Westover <kwestover.kw@gmail.com>
+
+pkgname='nuxhash-venv-git'
+pkgver=v1.0.0b2.r33.g33e9a09
+pkgrel=1
+pkgdesc="A NiceHash cryptocurrency mining client for Linux - Python 3.9 venv, fixes GUI problems."
+arch=('x86_64')
+url="https://github.com/YoRyan/nuxhash"
+license=('GPL3')
+depends=('python39' # https://github.com/YoRyan/nuxhash/issues/119
+ 'curl'
+ 'nvidia'
+ 'opencl-nvidia'
+ 'cuda')
+source=("git+https://github.com/YoRyan/nuxhash.git"
+ "fix-wx-issues.patch"
+ "fix-404.patch"
+ "nuxhashd.sh"
+ "nuxhash-gui.sh"
+ "nuxhash-gui.desktop")
+sha256sums=('SKIP'
+ '79c56a0fcc373cc76d5b627514103cb4914f7a45780f131ac4a81946b0371bbd'
+ '55d410a61aa080e0680091fbf3dd3e54837c11b60c13257d2c7e6b75395b20c6'
+ 'c6bc0d3c707091469ce2a91e906131a3b799afa46451ff21547b780cfac4cd0c'
+ '62d2c21495b5b0e3ff9354b585adc75816752ab2d9a5cc3e9af89ed77ed7e1c1'
+ '779c28c990c97b6c6fb2b2ad1cf84ff99dcdf5c1b72f034750994fdc8a645055')
+conflicts=('nuxhash-git')
+provides=('nuxhash-git')
+
+pkgver() {
+ cd nuxhash
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ patch -p1 < fix-wx-issues.patch
+ patch -p1 < fix-404.patch
+}
+
+package() {
+ export PIP_DISABLE_PIP_VERSION_CHECK=1
+ cd nuxhash
+ mkdir -p "$pkgdir"/opt/nuxhash
+ python3.9 -m venv "$pkgdir"/opt/nuxhash
+ source "$pkgdir"/opt/nuxhash/bin/activate
+ pip install wheel pypubsub
+ pip install wxpython .
+ install -Dm644 nuxhash/gui/icons/nuxhash.svg "$pkgdir"/usr/share/pixmaps/nuxhash.svg
+ install -Dm644 ../nuxhash-gui.desktop "$pkgdir"/usr/share/applications/nuxhash-gui.desktop
+ install -Dm755 ../nuxhashd.sh "$pkgdir"/usr/bin/nuxhashd
+ install -Dm755 ../nuxhash-gui.sh "$pkgdir"/usr/bin/nuxhash-gui
+}
diff --git a/fix-404.patch b/fix-404.patch
new file mode 100644
index 000000000000..d06e63246210
--- /dev/null
+++ b/fix-404.patch
@@ -0,0 +1,12 @@
+diff -r -U 0 a/nuxhash/nuxhash/nhrest/python/nicehash.py b/nuxhash/nuxhash/nhrest/python/nicehash.py
+--- a/nuxhash/nuxhash/nhrest/python/nicehash.py 2022-01-11 13:45:29.215436461 -0500
++++ b/nuxhash/nuxhash/nhrest/python/nicehash.py 2022-01-11 13:47:15.789264605 -0500
+@@ -165 +165 @@
+- return self.request('GET', '/main/api/v2/accounting/accounts/', '', None)
++ return self.request('GET', '/main/api/v2/accounting/accounts2/', '', None)
+diff -r -U 0 a/nuxhash/nuxhash/nicehash.py b/nuxhash/nuxhash/nicehash.py
+--- a/nuxhash/nuxhash/nicehash.py 2022-01-11 13:45:29.215436461 -0500
++++ b/nuxhash/nuxhash/nicehash.py 2022-01-11 13:47:26.635552456 -0500
+@@ -27 +27 @@
+- 'GET', f'/main/api/v2/mining/external/{address}/rigs/', '', None)
++ 'GET', f'/main/api/v2/mining/external/{address}/rigs2/', '', None)
diff --git a/fix-wx-issues.patch b/fix-wx-issues.patch
new file mode 100644
index 000000000000..fa998aa84d4d
--- /dev/null
+++ b/fix-wx-issues.patch
@@ -0,0 +1,32 @@
+diff -r -U 0 a/nuxhash/nuxhash/gui/benchmarks.py b/nuxhash/nuxhash/gui/benchmarks.py
+--- a/nuxhash/nuxhash/gui/benchmarks.py 2022-01-11 13:45:29.211436355 -0500
++++ b/nuxhash/nuxhash/gui/benchmarks.py 2022-01-11 13:54:25.729552602 -0500
+@@ -7 +7 @@
+-from wx.lib.pubsub import pub
++from pubsub import pub
+diff -r -U 0 a/nuxhash/nuxhash/gui/main.py b/nuxhash/nuxhash/gui/main.py
+--- a/nuxhash/nuxhash/gui/main.py 2022-01-11 13:45:29.211436355 -0500
++++ b/nuxhash/nuxhash/gui/main.py 2022-01-11 13:54:31.362631038 -0500
+@@ -10 +10 @@
+-from wx.lib.pubsub import pub
++from pubsub import pub
+diff -r -U 0 a/nuxhash/nuxhash/gui/mining.py b/nuxhash/nuxhash/gui/mining.py
+--- a/nuxhash/nuxhash/gui/mining.py 2022-01-11 13:45:29.211436355 -0500
++++ b/nuxhash/nuxhash/gui/mining.py 2022-01-11 13:56:53.792824763 -0500
+@@ -12 +12 @@
+-from wx.lib.pubsub import pub
++from pubsub import pub
+@@ -67,2 +67 @@
+- sizer.Add(bottomSizer, wx.SizerFlags().Border(wx.ALL, main.PADDING_PX)
+- .Expand())
++ sizer.Add(bottomSizer, wx.SizerFlags().Border(wx.ALL, main.PADDING_PX).Expand())
+@@ -91,2 +90 @@
+- bottomSizer.Add(self._StartStop, wx.SizerFlags().Expand()
+- .Center())
++ bottomSizer.Add(self._StartStop, wx.SizerFlags().Center())
+diff -r -U 0 a/nuxhash/nuxhash/gui/settings.py b/nuxhash/nuxhash/gui/settings.py
+--- a/nuxhash/nuxhash/gui/settings.py 2022-01-11 13:45:29.211436355 -0500
++++ b/nuxhash/nuxhash/gui/settings.py 2022-01-11 13:55:08.500165099 -0500
+@@ -5 +5 @@
+-from wx.lib.pubsub import pub
++from pubsub import pub
diff --git a/nuxhash-gui.desktop b/nuxhash-gui.desktop
new file mode 100644
index 000000000000..4b78ded88a48
--- /dev/null
+++ b/nuxhash-gui.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Name=Nuxhash
+Comment=A NiceHash cryptocurrency mining client for Linux.
+Exec=nuxhash-gui %u
+Terminal=false
+Type=Application
+Icon=nuxhash
+MimeType=x-scheme-handler/btchd;
+Categories=Internet;Finance;P2P;Network;Qt;
diff --git a/nuxhash-gui.sh b/nuxhash-gui.sh
new file mode 100755
index 000000000000..46d69210d9e5
--- /dev/null
+++ b/nuxhash-gui.sh
@@ -0,0 +1,3 @@
+#!/bin/bash
+source /opt/nuxhash/bin/activate
+nuxhash-gui "$@"
diff --git a/nuxhashd.sh b/nuxhashd.sh
new file mode 100755
index 000000000000..73c58410a15d
--- /dev/null
+++ b/nuxhashd.sh
@@ -0,0 +1,3 @@
+#!/bin/bash
+source /opt/nuxhash/bin/activate
+nuxhashd "$@"