summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--nvidia-3.19.patch22
-rw-r--r--nvidia-4.0.patch28
4 files changed, 2 insertions, 62 deletions
diff --git a/.SRCINFO b/.SRCINFO
index abee20813e24..a40635104bb4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -63,11 +63,7 @@ pkgbase = nvidia-304xx-ck
conflicts = nvidia-ck-silvermont
options = !strip
source = nv-drm.patch
- source = nvidia-3.19.patch
- source = nvidia-4.0.patch
md5sums = 2365f1405f0c7bbb8f8cd7ebd5e4e301
- md5sums = 965a8455b291fdb414a02101a3a9f587
- md5sums = f42bdf589f52d4e6c38baa5bef15eef8
source_i686 = http://us.download.nvidia.com/XFree86/Linux-x86/304.128/NVIDIA-Linux-x86-304.128.run
md5sums_i686 = be2b40a4dc3339b050a4f76ddd27e96c
source_x86_64 = http://us.download.nvidia.com/XFree86/Linux-x86_64/304.128/NVIDIA-Linux-x86_64-304.128-no-compat32.run
diff --git a/PKGBUILD b/PKGBUILD
index db54073566c3..eb3106f80249 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,14 +18,10 @@ conflicts=('nvidia-340xx-ck' 'nvidia-ck' 'nvidia-275xx-ck' 'nvidia-319-ck' 'nvid
license=('custom')
install=nvidia-304xx-ck.install
options=(!strip)
-source=('nv-drm.patch'
-'nvidia-3.19.patch'
-'nvidia-4.0.patch')
+source=('nv-drm.patch')
source_i686+=("http://us.download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run")
source_x86_64+=("http://us.download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run")
-md5sums=('2365f1405f0c7bbb8f8cd7ebd5e4e301'
- '965a8455b291fdb414a02101a3a9f587'
- 'f42bdf589f52d4e6c38baa5bef15eef8')
+md5sums=('2365f1405f0c7bbb8f8cd7ebd5e4e301')
md5sums_i686=('be2b40a4dc3339b050a4f76ddd27e96c')
md5sums_x86_64=('6478e40ed87d9177cbfc3d0b6e39a051')
[[ "$CARCH" = "i686" ]] && _pkg="NVIDIA-Linux-x86-${pkgver}"
@@ -35,8 +31,6 @@ prepare() {
sh "${_pkg}.run" --extract-only
cd "${_pkg}"
patch -Np0 -i "$srcdir/nv-drm.patch"
- patch -p1 -i "$srcdir/nvidia-3.19.patch"
- patch -p0 -i "$srcdir/nvidia-4.0.patch"
}
build() {
diff --git a/nvidia-3.19.patch b/nvidia-3.19.patch
deleted file mode 100644
index 2ace4237a0e7..000000000000
--- a/nvidia-3.19.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff -Npur NVIDIA-Linux-x86_64-304.orig/kernel/nv.c NVIDIA-Linux-x86_64-304.125-no-compat32/kernel/nv.c
---- NVIDIA-Linux-x86_64-304.orig/kernel/nv.c 2014-12-02 04:58:34.000000000 +0100
-+++ NVIDIA-Linux-x86_64-304.125-no-compat32/kernel/nv.c 2014-12-21 17:50:33.420697348 +0100
-@@ -2026,7 +2026,7 @@ long nv_kern_unlocked_ioctl(
- unsigned long i_arg
- )
- {
-- return nv_kern_ioctl(file->f_dentry->d_inode, file, cmd, i_arg);
-+ return nv_kern_ioctl(file->f_path.dentry->d_inode, file, cmd, i_arg);
- }
-
- long nv_kern_compat_ioctl(
-@@ -2035,7 +2035,7 @@ long nv_kern_compat_ioctl(
- unsigned long i_arg
- )
- {
-- return nv_kern_ioctl(file->f_dentry->d_inode, file, cmd, i_arg);
-+ return nv_kern_ioctl(file->f_path.dentry->d_inode, file, cmd, i_arg);
- }
-
- /*
-
diff --git a/nvidia-4.0.patch b/nvidia-4.0.patch
deleted file mode 100644
index 905ebeaf3fde..000000000000
--- a/nvidia-4.0.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- kernel/nv-pat.c~ 2015-02-22 20:39:43.889075396 -0800
-+++ kernel/nv-pat.c 2015-02-22 20:29:33.519735577 -0800
-@@ -35,8 +35,13 @@
- unsigned long cr0 = read_cr0();
- write_cr0(((cr0 & (0xdfffffff)) | 0x40000000));
- wbinvd();
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(4,0,0)
-+ *cr4 = __read_cr4();
-+ if (*cr4 & 0x80) __write_cr4(*cr4 & ~0x80);
-+#else
- *cr4 = read_cr4();
- if (*cr4 & 0x80) write_cr4(*cr4 & ~0x80);
-+#endif
- __flush_tlb();
- }
-
-@@ -46,7 +46,11 @@
- wbinvd();
- __flush_tlb();
- write_cr0((cr0 & 0x9fffffff));
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(4,0,0)
-+ if (cr4 & 0x80) __write_cr4(cr4);
-+#else
- if (cr4 & 0x80) write_cr4(cr4);
-+#endif
- }
-
- static int nv_determine_pat_mode(void)