summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
2 files changed, 12 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dcdf569a6680..6eb5387b42f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,20 @@
pkgbase = nvidia-beta-all
pkgdesc = NVIDIA drivers for all kernels on the system (beta version)
- pkgver = 440.44
- pkgrel = 2
+ pkgver = 440.59
+ pkgrel = 1
url = https://www.nvidia.com/
arch = x86_64
license = custom
makedepends = linux
makedepends = linux-headers
- depends = nvidia-utils-beta>=440.44
+ depends = nvidia-utils-beta>=440.59
depends = libglvnd
- provides = nvidia=440.44
- provides = nvidia-beta=440.44
+ provides = nvidia=440.59
+ provides = nvidia-beta=440.59
conflicts = nvidia
options = !strip
- source = https://us.download.nvidia.com/XFree86/Linux-x86_64/440.44/NVIDIA-Linux-x86_64-440.44-no-compat32.run
- source = 010-nvidia-prime-kernel-5.4.patch::https://gitlab.com/snippets/1929174/raw
- source = 020-nvidia-kernel-5.5.patch::https://gitlab.com/snippets/1923197/raw
- sha256sums = 794fdfc8e65c203ae482f59df7e55050ddcf0a11af2a95eaa1a10c7d48ec7e0f
- sha256sums = bedd55074771222bad8391c66b7022a266c135ff51d478710f7dda8708c3e9aa
- sha256sums = 7dcd609e85720cb812d7b41320d845931d8ea3e8529c700231372e0da66e5804
+ source = https://us.download.nvidia.com/XFree86/Linux-x86_64/440.59/NVIDIA-Linux-x86_64-440.59-no-compat32.run
+ sha256sums = 87c05aeadd260034b4d429de5be8032ead2103adee7aedc1adbb15c0ce3c6f28
pkgname = nvidia-beta-all
diff --git a/PKGBUILD b/PKGBUILD
index d013020a0bdb..94459ffeffae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Ng Oon-Ee
pkgname=nvidia-beta-all
-pkgver=440.44
-pkgrel=2
+pkgver=440.59
+pkgrel=1
pkgdesc='NVIDIA drivers for all kernels on the system (beta version)'
arch=('x86_64')
url='https://www.nvidia.com/'
@@ -15,12 +15,8 @@ provides=("nvidia=${pkgver}" "nvidia-beta=${pkgver}")
conflicts=('nvidia')
options=('!strip')
_pkg="NVIDIA-Linux-${CARCH}-${pkgver}-no-compat32"
-source=("https://us.download.nvidia.com/XFree86/Linux-${CARCH}/${pkgver}/${_pkg}.run"
- '010-nvidia-prime-kernel-5.4.patch::https://gitlab.com/snippets/1929174/raw'
- '020-nvidia-kernel-5.5.patch::https://gitlab.com/snippets/1923197/raw')
-sha256sums=('794fdfc8e65c203ae482f59df7e55050ddcf0a11af2a95eaa1a10c7d48ec7e0f'
- 'bedd55074771222bad8391c66b7022a266c135ff51d478710f7dda8708c3e9aa'
- '7dcd609e85720cb812d7b41320d845931d8ea3e8529c700231372e0da66e5804')
+source=("https://us.download.nvidia.com/XFree86/Linux-${CARCH}/${pkgver}/${_pkg}.run")
+sha256sums=('87c05aeadd260034b4d429de5be8032ead2103adee7aedc1adbb15c0ce3c6f28')
prepare() {
# extract the source file
@@ -33,27 +29,10 @@ prepare() {
# create a build directory for each installed kernel
local _kernel
local -a _kernels
- local _majver
mapfile -t _kernels < <(find /usr/lib/modules/*/build/version -exec cat {} +)
for _kernel in "${_kernels[@]}"
do
- _majver="$(printf "$_kernel" | sed -E 's/^([0-9]+\.[0-9]+).*/\1/')"
- cp -a kernel-orig kernel
-
- # current patches are for 5.4 and later only
- if [ "$(vercmp "$_majver" '5.4')" -ge '0' ]
- then
- printf '%s\n' " -> Applying patch(es) for kernel ${_kernel}..."
- patch -Np1 -i "${srcdir}/010-nvidia-prime-kernel-5.4.patch"
-
- if [ "$(vercmp "$_majver" '5.5')" -ge '0' ]
- then
- patch -Np1 -i "${srcdir}/020-nvidia-kernel-5.5.patch"
- fi
- fi
-
- mv kernel "kernel-${_kernel}"
- cp -a .manifest ".manifest-${_kernel}"
+ cp -a kernel-orig "kernel-${_kernel}"
done
}
@@ -65,7 +44,6 @@ build() {
for _kernel in "${_kernels[@]}"
do
cd "${srcdir}/${_pkg}/kernel-${_kernel}"
- cp -a "${srcdir}/${_pkg}/.manifest-${_kernel}" "${srcdir}/${_pkg}/.manifest"
printf '%s\n' " -> Building Nvidia module for ${_kernel}..."
make SYSSRC="/usr/lib/modules/${_kernel}/build" module
done