summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD15
-rw-r--r--linux-4.16.patch33
3 files changed, 11 insertions, 53 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f5d8ce988bf6..882d25d36081 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,22 @@
pkgbase = nvidia-beta-dkms
pkgdesc = NVIDIA driver sources for linux (beta version)
- pkgver = 418.56
+ pkgver = 430.09
pkgrel = 1
url = https://www.nvidia.com/
arch = x86_64
license = custom
makedepends = linux-headers
depends = dkms
- depends = nvidia-utils-beta>=418.56
+ depends = nvidia-utils-beta>=430.09
depends = libglvnd
optdepends = linux-headers: build the module for Arch kernel
optdepends = linux-lts-headers: build the module for LTS Arch kernel
- provides = nvidia=418.56
- provides = nvidia-dkms=418.56
- provides = nvidia-beta=418.56
+ provides = nvidia=430.09
+ provides = nvidia-dkms=430.09
+ provides = nvidia-beta=430.09
conflicts = nvidia
- source = https://us.download.nvidia.com/XFree86/Linux-x86_64/418.56/NVIDIA-Linux-x86_64-418.56-no-compat32.run
- source = linux-4.16.patch
- sha256sums = 5e5cfcc6a392ceee156d3a55fc1c1cdebd5831b371163c6028fe409cefbf9d43
- sha256sums = 622ac792ec200b2239cb663c0010392118b78c9904973d82cd261165c16d6385
+ source = https://us.download.nvidia.com/XFree86/Linux-x86_64/430.09/NVIDIA-Linux-x86_64-430.09-no-compat32.run
+ sha256sums = 247e127fcf1f1902193104f22ca69e1974f834b3c4502a0eba42312b8d6c88b9
pkgname = nvidia-beta-dkms
diff --git a/PKGBUILD b/PKGBUILD
index c695c31e0a3e..12dbb6ef0dd2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
# Contributor: sl1pkn07 <sl1pkn07 at gmail dot com>
pkgname=nvidia-beta-dkms
-pkgver=418.56
+pkgver=430.09
pkgrel=1
pkgdesc='NVIDIA driver sources for linux (beta version)'
arch=('x86_64')
@@ -22,10 +22,8 @@ optdepends=('linux-headers: build the module for Arch kernel'
provides=("nvidia=${pkgver}" "nvidia-dkms=${pkgver}" "nvidia-beta=${pkgver}")
conflicts=('nvidia')
_srcname="NVIDIA-Linux-${CARCH}-${pkgver}-no-compat32"
-source=("https://us.download.nvidia.com/XFree86/Linux-${CARCH}/${pkgver}/${_srcname}.run"
- 'linux-4.16.patch')
-sha256sums=('5e5cfcc6a392ceee156d3a55fc1c1cdebd5831b371163c6028fe409cefbf9d43'
- '622ac792ec200b2239cb663c0010392118b78c9904973d82cd261165c16d6385')
+source=("https://us.download.nvidia.com/XFree86/Linux-${CARCH}/${pkgver}/${_srcname}.run")
+sha256sums=('247e127fcf1f1902193104f22ca69e1974f834b3c4502a0eba42312b8d6c88b9')
prepare() {
# extract the source file
@@ -33,13 +31,8 @@ prepare() {
printf '%s\n' " -> Self-Extracting ${_srcname}.run..."
sh "${_srcname}.run" --extract-only
- # restore phys_to_dma support
- # https://bugs.archlinux.org/task/58074
- cd "$_srcname"
- patch -Np1 -i "${srcdir}/linux-4.16.patch"
-
# update dkms.conf
- cd kernel
+ cd "${_srcname}/kernel"
sed -i "s/__VERSION_STRING/${pkgver}/" dkms.conf
sed -i 's/__JOBS/`nproc`/' dkms.conf
sed -i 's/__DKMS_MODULES//' dkms.conf
diff --git a/linux-4.16.patch b/linux-4.16.patch
deleted file mode 100644
index 67172815ff69..000000000000
--- a/linux-4.16.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff --git a/kernel/common/inc/nv-linux.h b/kernel/common/inc/nv-linux.h
-index 10fc418..22ef968 100644
---- a/kernel/common/inc/nv-linux.h
-+++ b/kernel/common/inc/nv-linux.h
-@@ -175,7 +175,11 @@ static inline uid_t __kuid_val(kuid_t uid)
-
- #if defined(NV_VM_INSERT_PAGE_PRESENT)
- #include <linux/pagemap.h>
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 16, 0)
- #include <linux/dma-mapping.h>
-+#else
-+#include <linux/dma-direct.h>
-+#endif
- #endif
-
- #if defined(CONFIG_SWIOTLB) && defined(NVCPU_AARCH64)
-diff --git a/kernel/conftest.sh b/kernel/conftest.sh
-index b23dbb4..42dc576 100755
---- a/kernel/conftest.sh
-+++ b/kernel/conftest.sh
-@@ -1906,7 +1906,12 @@ compile_test() {
- # Determine if the phys_to_dma function is present.
- #
- CODE="
-+ #include <linux/version.h>
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 16, 0)
- #include <linux/dma-mapping.h>
-+#else
-+ #include <linux/dma-direct.h>
-+#endif
- void conftest_phys_to_dma(void) {
- phys_to_dma();
- }"