summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cabe827d6b47
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = nvidia-launcher
+ pkgdesc = Launch applications with NVIDIA graphics card
+ pkgver = 0.7
+ pkgrel = 1
+ url = https://gitlab.com/WheelchairArtist/nvidia-launcher
+ arch = x86_64
+ license = GPL2
+ makedepends = gendesk
+ depends = kdialog
+ depends = bumblebee
+ optdepends = primusrun
+ source = https://gitlab.com/WheelchairArtist/nvidia-launcher/raw/0.7/nvidia-launcher
+ sha256sums = 807fe8c271e82ce0c258845273af452e3a0775bfda4cea89405e20d315dde172
+
+pkgname = nvidia-launcher
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8b4d3fe3a536
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Kazel <address at domain dot tld>
+pkgname=nvidia-launcher
+pkgver=0.7
+pkgrel=1
+pkgdesc="Launch applications with NVIDIA graphics card"
+arch=(x86_64)
+url="https://gitlab.com/WheelchairArtist/nvidia-launcher"
+license=('GPL2')
+depends=(kdialog bumblebee)
+makedepends=(gendesk)
+optdepends=(primusrun)
+changelog=
+source=(https://gitlab.com/WheelchairArtist/$pkgname/raw/$pkgver/nvidia-launcher)
+noextract=()
+sha256sums=('807fe8c271e82ce0c258845273af452e3a0775bfda4cea89405e20d315dde172')
+
+
+prepare() {
+ gendesk --pkgname="$pkgname" --pkgdesc="$pkgdesc" --name="Nvidia Launcher" --comment="$pkgdesc" --exec="/usr/bin/$pkgname" --categories="Utility"
+}
+
+
+package() {
+ install -Dm 755 -o root -g root nvidia-launcher "$pkgdir/usr/bin/nvidia-launcher"
+ install -Dm 644 -o root -g root "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm 644 -o root -g root "$pkgname.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
+}