summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xupdate.sh24
1 files changed, 24 insertions, 0 deletions
diff --git a/update.sh b/update.sh
new file mode 100755
index 000000000000..85f82f473e7e
--- /dev/null
+++ b/update.sh
@@ -0,0 +1,24 @@
+#!/bin/bash
+
+if (( $# != 1 )); then
+ echo "Usage: $0 VERSION"
+ echo "Update pkgver to VERSION and then build and commit."
+ echo "You just need to test the package, review the commit and push."
+ exit 1
+fi
+
+VERSION=$1
+
+set -x
+
+sed -i "s/^pkgver=.*\$/pkgver=${VERSION}/" PKGBUILD
+updpkgsums
+mksrcinfo
+git add .
+git commit -m "Upgrade to v${VERSION}"
+makepkg
+sudo pacman -U nvm-${VERSION}-1-any.pkg.tar.xz
+
+set +x
+
+echo "Now smoke test the package, review the commit, and push"