summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--nvm-git.install22
3 files changed, 19 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2d9fc4f2114..23024c2039b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nvm-git
- pkgdesc = Simple bash script to manage multiple active node.js versions (git sources)
+ pkgdesc = Node Version Manager - Simple bash script to manage multiple active node.js versions (git sources)
pkgver = 0.29.0.r0.ge1c84ba
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/creationix/nvm
install = nvm-git.install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 1e8362c95d5c..a4f3ebec1532 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Tom Wadley <tom@tomwadley.net>
pkgname=nvm-git
-pkgver=0.29.0.r0.ge1c84ba
+pkgver=0.29.0.r25.g9972de6
pkgrel=1
-pkgdesc="Simple bash script to manage multiple active node.js versions (git sources)"
+pkgdesc="Node Version Manager - Simple bash script to manage multiple active node.js versions (git sources)"
url="https://github.com/creationix/nvm"
arch=('any')
license=('MIT')
@@ -30,7 +30,7 @@ package() {
cd "${pkgname}"
- # nvm.sh
+ # nvm itself
install -Dm644 nvm.sh "$pkgdir/usr/share/nvm/nvm.sh"
# bash completion
diff --git a/nvm-git.install b/nvm-git.install
index 88a452e767b7..b9b188a7cb03 100644
--- a/nvm-git.install
+++ b/nvm-git.install
@@ -2,20 +2,26 @@
post_install() {
echo "
You need to source nvm before you can use it. Do one of the following
-or similar depending on your shell:
+or similar depending on your shell (and then restart your shell):
echo 'source /usr/share/nvm/init-nvm.sh' >> ~/.bashrc
echo 'source /usr/share/nvm/init-nvm.sh' >> ~/.zprofile
-Alternatively, you can copy the contents of init-nvm.sh to your
-.bashrc (or similar) if you would like an NVM_DIR other than ~/.nvm
+You can now install node.js versions (e.g. nvm install 5.0) and
+activate them (e.g. nvm use 5.0). You may want to activate your
+preferred node.js version in your .bashrc (or similar) after
+sourcing init-nvm.sh.
+
+init-nvm.sh is a convenience script which does the following:
"
-}
+ cat usr/share/nvm/init-nvm.sh
+ echo "
+You may wish to customize and put these lines directly in your
+.bashrc (or similar) if, for example, you would like an NVM_DIR
+other than ~/.nvm or you don't want bash completion.
-## arg 1: the new package version
-## arg 2: the old package version
-post_upgrade() {
- post_install
+See the nvm readme for more information: https://github.com/creationix/nvm
+"
}
## arg 1: the old package version