summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
2 files changed, 15 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2da0a4a51a8a..f7a7e216fdcc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nwg-shell
pkgdesc = nwg-shell meta-package and installer
- pkgver = 0.0.3
- pkgrel = 4
+ pkgver = 0.1.0
+ pkgrel = 1
url = https://github.com/nwg-piotr/nwg-shell
arch = x86_64
license = MIT
@@ -10,6 +10,7 @@ pkgbase = nwg-shell
depends = foot
depends = gnome-themes-extra
depends = grim
+ depends = imagemagick
depends = jq
depends = libappindicator-gtk3
depends = light
@@ -20,6 +21,7 @@ pkgbase = nwg-shell
depends = playerctl
depends = polkit-gnome
depends = python-geopy
+ depends = python-yaml
depends = slurp
depends = swappy
depends = sway
@@ -45,7 +47,7 @@ pkgbase = nwg-shell
optdepends = mousepad: suggested text editor
optdepends = thunar: suggested file manager
optdepends = nano: in case you hate vi
- source = nwg-shell-0.0.3.tar.gz::https://github.com/nwg-piotr/nwg-shell/archive/v0.0.3.tar.gz
- md5sums = SKIP
+ source = nwg-shell-0.1.0.tar.gz::https://github.com/nwg-piotr/nwg-shell/archive/v0.1.0.tar.gz
+ md5sums = 4f156748380531f2fc7b2bf4b49c4214
pkgname = nwg-shell
diff --git a/PKGBUILD b/PKGBUILD
index 41262102f2e2..7d86f6ab64f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
# Maintainer: Piotr Miller <nwg.piotr@gmail.com>
pkgname=('nwg-shell')
-pkgver=0.0.3
-pkgrel=4
+pkgver=0.1.0
+pkgrel=1
pkgdesc="nwg-shell meta-package and installer"
arch=('x86_64')
url="https://github.com/nwg-piotr/nwg-shell"
license=('MIT')
-depends=('foot' 'gnome-themes-extra' 'grim' 'jq' 'libappindicator-gtk3' 'light' 'lxappearance'
- 'noto-fonts' 'pacman-contrib' 'papirus-icon-theme' 'playerctl' 'polkit-gnome'
- 'python-geopy' 'slurp' 'swappy' 'sway' 'swayidle' 'swaylock' 'wl-clipboard' 'xorg-xwayland'
- 'autotiling' 'azote' 'gopsuinfo' 'nwg-bar-bin' 'nwg-dock-bin' 'nwg-drawer-bin' 'nwg-menu-bin'
- 'nwg-panel' 'nwg-shell-config' 'nwg-wrapper' 'python-dasbus' 'swaync' 'wdisplays' 'wlsunset')
+depends=('foot' 'gnome-themes-extra' 'grim' 'imagemagick' 'jq' 'libappindicator-gtk3' 'light'
+ 'lxappearance' 'noto-fonts' 'pacman-contrib' 'papirus-icon-theme' 'playerctl' 'polkit-gnome'
+ 'python-geopy' 'python-yaml' 'slurp' 'swappy' 'sway' 'swayidle' 'swaylock' 'wl-clipboard'
+ 'xorg-xwayland' 'autotiling' 'azote' 'gopsuinfo' 'nwg-bar-bin' 'nwg-dock-bin'
+ 'nwg-drawer-bin' 'nwg-menu-bin' 'nwg-panel' 'nwg-shell-config' 'nwg-wrapper' 'python-dasbus'
+ 'swaync' 'wdisplays' 'wlsunset')
optdepends=('chromium: suggested web browser'
'mousepad: suggested text editor'
'thunar: suggested file manager'
@@ -18,7 +19,7 @@ optdepends=('chromium: suggested web browser'
makedepends=('python-setuptools' 'python-wheel')
source=("$pkgname-$pkgver.tar.gz::https://github.com/nwg-piotr/nwg-shell/archive/v"$pkgver".tar.gz")
-md5sums=('SKIP')
+md5sums=('4f156748380531f2fc7b2bf4b49c4214')
package() {
cd "${pkgname}-${pkgver}"