summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 20 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4604fe5485e5..45e2334279f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,20 @@
pkgbase = nwipe
pkgdesc = A fork of the dwipe command that will securely erase disks using a variety of recognised methods
- pkgver = 0.24
+ pkgver = 0.36
pkgrel = 1
url = http://www.andybev.com/index.php/Nwipe
arch = i686
arch = x86_64
+ arch = aarch64
license = GPL2
- depends = device-mapper
+ depends = hdparm
+ depends = libconfig
depends = ncurses
depends = parted
- source = https://github.com/martijnvanbrummelen/nwipe/archive/v0.24.tar.gz
- md5sums = 902ce622c67a639a247c55be399ccc0e
+ optdepends = coreutils
+ optdepends = dmidecode
+ optdepends = smartmontools
+ source = https://github.com/martijnvanbrummelen/nwipe/archive/v0.36.tar.gz
+ sha256sums = 4165a02fdfbf91a22bf862b35f057d7672052ef02509c97387068b5df6bb5c5b
pkgname = nwipe
-
diff --git a/PKGBUILD b/PKGBUILD
index 98e424d0ef5d..9657edc2a52a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,26 @@
# Contributor: <kfgz at interia dot pl>
pkgname=nwipe
-pkgver=0.24
+pkgver=0.36
pkgrel=1
pkgdesc="A fork of the dwipe command that will securely erase disks using a variety of recognised methods"
-arch=('i686' 'x86_64')
+arch=('i686' 'x86_64' 'aarch64')
url="http://www.andybev.com/index.php/Nwipe"
-depends=('device-mapper' 'ncurses' 'parted')
+depends=('hdparm' 'libconfig' 'ncurses' 'parted')
+optdepends=('coreutils' 'dmidecode' 'smartmontools')
license=('GPL2')
source=("https://github.com/martijnvanbrummelen/nwipe/archive/v${pkgver}.tar.gz")
build() {
- cd "${srcdir}"/${pkgname}-${pkgver}
- ./init.sh
- ./configure --prefix=/usr
- make
+ cd "${srcdir}"/${pkgname}-${pkgver}
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
}
package() {
- cd "${srcdir}"/${pkgname}-${pkgver}
- make DESTDIR="${pkgdir}" install
+ cd "${srcdir}"/${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
}
-md5sums=('902ce622c67a639a247c55be399ccc0e')
+sha256sums=('4165a02fdfbf91a22bf862b35f057d7672052ef02509c97387068b5df6bb5c5b')