summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
-rw-r--r--nwmouse.nwlogger.patch22
3 files changed, 7 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d810f59041cc..8e55c9877863 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nwn-diamond
pkgdesc = Neverwinter Nights is an RPG from Bioware. This requires the Diamond Collection DVD Release.
pkgver = 1.69
- pkgrel = 3
+ pkgrel = 4
url = http://nwn.bioware.com/
install = nwn.install
arch = i686
@@ -11,7 +11,7 @@ pkgbase = nwn-diamond
makedepends = p7zip
makedepends = perl
depends = binkplayer
- depends = libelf
+ depends = elfutils
depends = libgl
depends = libstdc++5
depends = libxcursor
@@ -30,7 +30,6 @@ pkgbase = nwn-diamond
source = http://home.roadrunner.com/~nwmovies/cursors.tar.gz
source = nwn.launcher
source = nwn.desktop
- source = nwmouse.nwlogger.patch
md5sums = 0a059d55225fc32f905e86191d88a11f
md5sums = 376cdece07106ea058d42b531f3146bb
md5sums = b021f0da3b3e00848521926716fdf487
@@ -41,7 +40,6 @@ pkgbase = nwn-diamond
md5sums = 7be935418f0ececb5660f53b7a902b38
md5sums = d28e09031cc8f56406f6878e36683e36
md5sums = bd7f80f5faa5ee1203371b4e8ec40638
- md5sums = 95d96bf43557405586c7dab01ffc8d8c
pkgname = nwn-diamond
diff --git a/PKGBUILD b/PKGBUILD
index 9ebbd5ed2c4c..04e5fd6877e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,15 @@
pkgname=nwn-diamond
pkgver=1.69
-pkgrel=3
+pkgrel=4
pkgdesc="Neverwinter Nights is an RPG from Bioware. This requires the Diamond Collection DVD Release."
url="http://nwn.bioware.com/"
license=('custom')
arch=('i686' 'x86_64')
if [ "$CARCH" = "x86_64" ]; then
- depends=('binkplayer' 'lib32-libelf' 'lib32-libgl' 'lib32-libstdc++5' 'lib32-libxcursor' 'lib32-libxdamage' 'lib32-mesa' 'perl' 'lib32-sdl_mixer')
+ depends=('binkplayer' 'lib32-elfutils' 'lib32-libgl' 'lib32-libstdc++5' 'lib32-libxcursor' 'lib32-libxdamage' 'lib32-mesa' 'perl' 'lib32-sdl_mixer')
else
- depends=('binkplayer' 'libelf' 'libgl' 'libstdc++5' 'libxcursor' 'mesa' 'perl' 'sdl_mixer')
+ depends=('binkplayer' 'elfutils' 'libgl' 'libstdc++5' 'libxcursor' 'mesa' 'perl' 'sdl_mixer')
fi
makedepends=('unzip' 'p7zip' 'perl')
provides=('nwn')
@@ -25,7 +25,7 @@ source=("http://nwdownloads.bioware.com/neverwinternights/linux/gold/nwclientgol
"http://home.roadrunner.com/~nwmovies/nwmouse/nwmouse-latest.tar.gz" \
"http://home.roadrunner.com/~nwmovies/nwlogger/nwlogger-latest.tar.gz" \
"http://home.roadrunner.com/~nwmovies/cursors.tar.gz" \
-"nwn.launcher" "nwn.desktop" "nwmouse.nwlogger.patch")
+"nwn.launcher" "nwn.desktop")
md5sums=('0a059d55225fc32f905e86191d88a11f'
'376cdece07106ea058d42b531f3146bb'
'b021f0da3b3e00848521926716fdf487'
@@ -35,8 +35,7 @@ md5sums=('0a059d55225fc32f905e86191d88a11f'
'981d5cd5ec13aa888e4c0a2ba7f9a231'
'7be935418f0ececb5660f53b7a902b38'
'd28e09031cc8f56406f6878e36683e36'
- 'bd7f80f5faa5ee1203371b4e8ec40638'
- '95d96bf43557405586c7dab01ffc8d8c')
+ 'bd7f80f5faa5ee1203371b4e8ec40638')
# Directory where the NWN Diamond DVD is Mounted
_dvdpath=/media/dvd
@@ -95,9 +94,6 @@ EOF
cd $srcdir/
- # Patch nwmouse and nwlogger so they build properly
- patch -p1 < $srcdir/nwmouse.nwlogger.patch
-
# Movies in Linux Client Support for NWN
./nwmovies_install.pl /usr/lib/libSDL.so
install -D -m 755 -t $pkgdir/opt/nwn/ \
diff --git a/nwmouse.nwlogger.patch b/nwmouse.nwlogger.patch
deleted file mode 100644
index 8020eda905c6..000000000000
--- a/nwmouse.nwlogger.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff -uNr a/nwlogger/nwlogger_cookie.c b/nwlogger/nwlogger_cookie.c
---- a/nwlogger/nwlogger_cookie.c 2004-03-09 14:40:36.000000000 -0500
-+++ b/nwlogger/nwlogger_cookie.c 2009-01-03 23:12:46.732146888 -0500
-@@ -16,7 +16,6 @@
- #include <elf.h>
- #include <libelf.h>
-
--#include <linux/user.h>
- #include <link.h>
-
- #include "libdis.h"
-diff -uNr a/nwmouse/nwmouse_cookie.c b/nwmouse/nwmouse_cookie.c
---- a/nwmouse/nwmouse_cookie.c 2004-09-24 14:17:42.000000000 -0400
-+++ b/nwmouse/nwmouse_cookie.c 2009-01-03 23:12:19.165487280 -0500
-@@ -16,7 +16,6 @@
- #include <elf.h>
- #include <libelf.h>
-
--#include <linux/user.h>
- #include <link.h>
-
- #include "libdis.h"