summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 30 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7ec267ff9e98..45f5e65c7e3f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,31 +1,30 @@
pkgbase = nyxt-browser-git
- pkgdesc = Keyboard-oriented, Common Lisp extensible web-browser
- pkgver = 1.5.0.r1236.g10fdbf5b
+ pkgdesc = A keyboard-driven web browser designed for power users
+ pkgver = latest
pkgrel = 1
url = https://nyxt.atlas.engineer
arch = i686
arch = x86_64
- license = BSD-3
+ license = custom:BSD
makedepends = git
makedepends = sbcl
makedepends = cl-asdf
- depends = webkit2gtk
+ depends = enchant
depends = glib-networking
+ depends = gobject-introspection-runtime
depends = gsettings-desktop-schemas
depends = libfixposix
- depends = enchant
+ depends = webkit2gtk-4.1
optdepends = gstreamer: for HTML5 audio/video
optdepends = gst-plugins-base: for HTML5 audio/video
optdepends = gst-plugins-good: for HTML5 audio/video
optdepends = gst-plugins-bad: for HTML5 audio/video
optdepends = gst-plugins-ugly: for HTML5 audio/video
- provides = nyxt-browser
- provides = next-browser
- conflicts = nyxt-browser
+ provides = nyxt
+ conflicts = nyxt
options = !strip
options = !makeflags
source = nyxt-browser::git+https://github.com/atlas-engineer/nyxt.git
sha256sums = SKIP
pkgname = nyxt-browser-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 51c96cbb4f9a..713472ea778f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,27 @@
-# Maintainer: Cillian Berragan <cjberragan@gmail.com>
+# Maintainer: MithicSpirit <rpc01234 at gmail dot com>
+# Contributor: Cillian Berragan <cjberragan@gmail.com>
# Contributor: Felix Golatofski <contact@xdfr.de>
_pkgname=nyxt-browser
pkgname=$_pkgname-git
-pkgver=1.5.0.r1236.g10fdbf5b
+pkgver=latest
pkgrel=1
-pkgdesc="Keyboard-oriented, Common Lisp extensible web-browser"
+pkgdesc='A keyboard-driven web browser designed for power users'
arch=('i686' 'x86_64')
-url="https://nyxt.atlas.engineer"
-license=('BSD-3')
-conflicts=('nyxt-browser')
-provides=('nyxt-browser' 'next-browser')
+url='https://nyxt.atlas.engineer'
+license=('custom:BSD')
+conflicts=('nyxt')
+provides=('nyxt')
source=($_pkgname::git+https://github.com/atlas-engineer/nyxt.git)
sha256sums=('SKIP')
# If someday Next works with other Lisps, replace 'sbcl' with 'common-lisp'.
makedepends=('git' 'sbcl' 'cl-asdf')
-depends=('webkit2gtk' 'glib-networking' 'gsettings-desktop-schemas' 'libfixposix' 'enchant')
+depends=('enchant'
+ 'glib-networking'
+ 'gobject-introspection-runtime'
+ 'gsettings-desktop-schemas'
+ 'libfixposix'
+ 'webkit2gtk-4.1')
optdepends=('gstreamer: for HTML5 audio/video'
'gst-plugins-base: for HTML5 audio/video'
'gst-plugins-good: for HTML5 audio/video'
@@ -27,7 +33,12 @@ options=('!strip' '!makeflags')
pkgver() {
cd "$srcdir/$_pkgname"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+prepare() {
+ cd "$srcdir/$_pkgname"
+ git submodule init
+ git submodule update
}
build() {
@@ -37,6 +48,7 @@ build() {
package() {
cd "$srcdir/$_pkgname"
- make install PREFIX=/usr DESTDIR=${pkgdir}
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$_pkgname/LICENSE
+ make install PREFIX=/usr DESTDIR="${pkgdir}"
+ install -dm755 "$pkgdir"/usr/share/licenses/$pkgname/
+ install -m644 licenses/* "$pkgdir"/usr/share/licenses/$pkgname/
}