summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
-rw-r--r--skip-unneeded-builds.patch15
3 files changed, 22 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 63ec01d7deab..9b91e112af96 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -21,6 +21,7 @@ pkgbase = nzbhydra2
source = wrapper-remove-base-path-checks.patch
source = wrapper-remove-update-support.patch
source = disable-update-checks.patch
+ source = skip-unneeded-builds.patch
sha256sums = 41a68b58630a9e535bc164700603ef088213bdb0a97fe68441c149e7e1d03074
sha256sums = 2fae64a1c5979d9f7b508f1e15d0f013b7cca1f2bbbdae56f546f4c362146b68
sha256sums = a9ceeed2b50d55c5e554c0d4c615e855fe4d3889eb118e37908fa04ffb7cb003
@@ -30,5 +31,6 @@ pkgbase = nzbhydra2
sha256sums = fd6ba3e8b22f3f90c19d9903445b2539837dca1c12df49863b2e8d1085d88b0e
sha256sums = f302b8dc8ed95ce18d67305a0460b1e62a4e4586fba0f77d3dd980a77cfba3d4
sha256sums = 83b4071b2fe02e9a302fda5b9b0de97e7531b6032cdbcb8148e2f0b1fc566a22
+ sha256sums = 693c834e641b54fd940490e522dba49d3f7a9846554181e2d284acdd81d87c38
pkgname = nzbhydra2
diff --git a/PKGBUILD b/PKGBUILD
index 24b3d1d9da1d..a8a466307169 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,7 +20,8 @@ source=("${pkgname}-${pkgver}.tar.gz::https://github.com/theotherp/nzbhydra2/arc
'wrapper-Fix-dropping-every-second-line-of-stdout-807.patch'
'wrapper-remove-base-path-checks.patch'
'wrapper-remove-update-support.patch'
- 'disable-update-checks.patch')
+ 'disable-update-checks.patch'
+ 'skip-unneeded-builds.patch')
sha256sums=('41a68b58630a9e535bc164700603ef088213bdb0a97fe68441c149e7e1d03074'
'2fae64a1c5979d9f7b508f1e15d0f013b7cca1f2bbbdae56f546f4c362146b68'
@@ -30,13 +31,15 @@ sha256sums=('41a68b58630a9e535bc164700603ef088213bdb0a97fe68441c149e7e1d03074'
'd59bb189f178170c523550a032af7bc5f4c90518b3bca8a631403d6725bd6528'
'fd6ba3e8b22f3f90c19d9903445b2539837dca1c12df49863b2e8d1085d88b0e'
'f302b8dc8ed95ce18d67305a0460b1e62a4e4586fba0f77d3dd980a77cfba3d4'
- '83b4071b2fe02e9a302fda5b9b0de97e7531b6032cdbcb8148e2f0b1fc566a22')
+ '83b4071b2fe02e9a302fda5b9b0de97e7531b6032cdbcb8148e2f0b1fc566a22'
+ '693c834e641b54fd940490e522dba49d3f7a9846554181e2d284acdd81d87c38')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
patch -p1 < "${srcdir}/wrapper-remove-base-path-checks.patch"
patch -p1 < "${srcdir}/wrapper-remove-update-support.patch"
patch -p1 < "${srcdir}/disable-update-checks.patch"
+ patch -p1 < "${srcdir}/skip-unneeded-builds.patch"
# TODO: remove on next release
patch -p1 < "${srcdir}/wrapper-Fix-dropping-every-second-line-of-stdout-807.patch"
}
diff --git a/skip-unneeded-builds.patch b/skip-unneeded-builds.patch
new file mode 100644
index 000000000000..7a0c02ee4c93
--- /dev/null
+++ b/skip-unneeded-builds.patch
@@ -0,0 +1,15 @@
+diff --git a/other/pom.xml b/other/pom.xml
+index d36645c8..93ba61cc 100644
+--- a/other/pom.xml
++++ b/other/pom.xml
+@@ -10,10 +10,7 @@
+ <packaging>pom</packaging>
+
+ <modules>
+- <module>mockserver</module>
+ <module>sockslib</module>
+- <module>github-release-plugin</module>
+- <module>discordbot</module>
+ </modules>
+
+ <properties>