summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac5c0bde8f22..94f402e217e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,14 @@
-# Generated by mksrcinfo v8
-# Sun Jan 26 15:27:42 UTC 2020
pkgbase = o
pkgdesc = Small, fast and VT100-compatible text editor
- pkgver = 2.15.3
+ pkgver = 2.23.0
pkgrel = 1
url = https://github.com/xyproto/o
arch = x86_64
license = BSD
makedepends = git
makedepends = go-pie
- makedepends = upx
options = !strip
- source = git+https://github.com/xyproto/o#tag=2.15.3
+ source = git+https://github.com/xyproto/o#commit=40996ac65f14cdb8b41f62b1f331a1a60ab0421e
sha256sums = SKIP
pkgname = o
diff --git a/PKGBUILD b/PKGBUILD
index 713c11c435b9..ee3529ab9516 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,30 @@
# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
pkgname=o
-pkgver=2.15.3
+pkgver=2.23.0
pkgrel=1
pkgdesc='Small, fast and VT100-compatible text editor'
arch=(x86_64)
url='https://github.com/xyproto/o'
license=(BSD)
-makedepends=(git go-pie upx)
-source=("git+$url#tag=$pkgver")
+makedepends=(git go-pie)
+source=("git+$url#commit=40996ac65f14cdb8b41f62b1f331a1a60ab0421e") # tag: 2.23.0
sha256sums=('SKIP')
options=(!strip)
build() {
cd "$pkgname"
- # Using gccgo gives a smaller size, but forces AUR users to juggle between go and gccgo, which is unfortunate
- #go build -buildmode=pie -gccgoflags="-s -w $LDFLAGS"
+ # Using gccgo + upx gives a smaller size
+ #go build -buildmode=pie -gccgoflags="-s -w $LDFLAGS" && upx o
go build -buildmode=pie -gcflags="all=-trimpath=$PWD" -asmflags "all=-trimpath=$PWD" -ldflags "-s -w -extldflags $LDFLAGS"
- upx o
}
package() {
install -Dm755 $pkgname/o "$pkgdir/usr/bin/o"
install -Dm644 $pkgname/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 $pkgname/o.1 "$pkgdir/usr/share/man/man1/o.1"
}
# vim: ts=2 sw=2 et: