summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD12
2 files changed, 5 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 04723b330901..469dc7301585 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,6 +8,7 @@ pkgbase = o20-git
makedepends = git
makedepends = cmake
makedepends = extra-cmake-modules
+ makedepends = qt5-tools
depends = zlib
depends = syntax-highlighting
depends = sonnet
@@ -25,6 +26,8 @@ pkgbase = o20-git
depends = ttf-roboto
depends = ttf-roboto-mono
depends = ttf-opensans
+ depends = ttf-ubuntu-font-family
+ depends = ttf-roboto-slab
provides = o20
conflicts = o20
source = o20-git::git+https://gitlab.com/abstractsoftware/o20/o20coreapps.git
diff --git a/PKGBUILD b/PKGBUILD
index b624ac834c54..2e959604fc1f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ license=('GPL')
depends=(zlib syntax-highlighting sonnet breeze
qt5-{base,svg,quickcontrols{,2}}
k{textwidgets,widgetsaddons,archive,config,iconthemes,coreaddons}
- ttf-roboto ttf-roboto-mono ttf-opensans
+ ttf-roboto ttf-roboto-mono ttf-opensans ttf-ubuntu-font-family ttf-roboto-slab
)
makedepends=(git cmake extra-cmake-modules qt5-tools)
provides=(${pkgname/-git/})
@@ -25,7 +25,6 @@ pkgver() {
build() {
cd "${pkgname}"
mkdir -p build && cd build
- # TODO: Use existing font packages instead
cmake \
-DCOMPILE_ONLY_WORD=On \
-DINSTALL_FONT=Off \
@@ -37,15 +36,8 @@ package() {
cd "${pkgname}/build"
make DESTDIR="${pkgdir}" install
cd ..
- install -Dm644 -t "${pkgdir}/usr/share/licenses/o20" \
- COPYING LICENSE
+ install -Dm644 -t "${pkgdir}/usr/share/licenses/o20" COPYING LICENSE
cd dev
- # Some fonts are on AUR, I am still thinking about whether
- # to put them in dependencies
- find o20.fonts/Roboto -name 'RobotoSlab*.ttf' -exec \
- install -Dm644 {} "${pkgdir}/usr/share/fonts/"{} \;
- find o20.fonts/Ubuntu -name 'Ubuntu*.ttf' -exec \
- install -Dm644 {} "${pkgdir}/usr/share/fonts/"{} \;
find o20.fonts/Lobster -type f -exec \
install -Dm644 {} "${pkgdir}/usr/share/fonts/"{} \;
}