summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD20
2 files changed, 18 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 910613fafeb3..7f6052fc0157 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = obhud
pkgdesc = Script for handling laptop-specific keys in Openbox
- pkgver = 0.0.1
- pkgrel = 7
+ pkgver = 0.1.0
+ pkgrel = 1
url = https://github.com/nwg-piotr/obhud
arch = i686
arch = x86_64
- license = gpl3
+ license = GPL3
depends = xorg-xbacklight
depends = xorg-xrandr
depends = libxrandr
@@ -14,10 +14,12 @@ pkgbase = obhud
depends = python-pmw
depends = python-pillow
depends = python-psutil
- source = https://github.com/nwg-piotr/obhud/raw/master/dist/obhud-0.0.1.tar.gz
+ source = https://github.com/nwg-piotr/obhud/raw/master/dist/obhud-0.1.0.tar.gz
source = https://github.com/nwg-piotr/obhud/raw/master/dist/obhud
- md5sums = 614fdf95147cb7b3c15cd87fa3e85e65
+ source = https://github.com/nwg-piotr/obhud/raw/master/dist/obhud.conf
+ md5sums = 37f21dc474fd0c0002e3a3bfd1eaf0da
md5sums = 5b26cb8e7fff160d1eccc183e8ae2d28
+ md5sums = 943101fced79c8986debb8bb5406e370
pkgname = obhud
diff --git a/PKGBUILD b/PKGBUILD
index 4f15319a51e0..98c0d71ed773 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,25 @@
# Maintainer: Piotr Miller <nwg.piotr@gmail.com>
pkgname=('obhud')
-pkgver=0.0.1
-pkgrel=7
+pkgver=0.1.0
+pkgrel=1
pkgdesc="Script for handling laptop-specific keys in Openbox"
arch=('i686' 'x86_64')
url="https://github.com/nwg-piotr/obhud"
-license=('gpl3')
+license=('GPL3')
depends=('xorg-xbacklight' 'xorg-xrandr' 'libxrandr' 'alsa-utils' 'python' 'python-pmw' 'python-pillow' 'python-psutil')
-source=("https://github.com/nwg-piotr/obhud/raw/master/dist/obhud-0.0.1.tar.gz"
-"https://github.com/nwg-piotr/obhud/raw/master/dist/obhud")
+source=("https://github.com/nwg-piotr/obhud/raw/master/dist/obhud-0.1.0.tar.gz"
+"https://github.com/nwg-piotr/obhud/raw/master/dist/obhud"
+"https://github.com/nwg-piotr/obhud/raw/master/dist/obhud.conf")
-md5sums=('614fdf95147cb7b3c15cd87fa3e85e65'
- '5b26cb8e7fff160d1eccc183e8ae2d28')
+md5sums=('37f21dc474fd0c0002e3a3bfd1eaf0da'
+ '5b26cb8e7fff160d1eccc183e8ae2d28'
+ '943101fced79c8986debb8bb5406e370')
package() {
install -D -m 755 obhud \
"$pkgdir"/usr/bin/obhud
+ install -D -m 644 obhud.conf \
+ "$pkgdir"/etc/obhud/obhud.conf
cd "$srcdir/$pkgname-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1
}
-
-# vim:set ts=2 sw=2 et: