summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD24
2 files changed, 15 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb5e6d440116..790bb5188039 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,10 @@
+# Generated by mksrcinfo v8
+# Thu Feb 9 21:23:32 UTC 2017
pkgbase = obozrenie-git
pkgdesc = Simple and easy to use game server browser
- pkgver = r224.3f2815b
+ pkgver = r252.a113ab8
pkgrel = 1
- url = http://github.com/obozrenie
+ url = https://github.com/vorot93/obozrenie
install = obozrenie.install
arch = any
license = GPL3
@@ -21,9 +23,7 @@ pkgbase = obozrenie-git
depends = qstat
optdepends = python-pygeoip: for geolocation support
optdepends = geoip-database: for geolocation support
- provides = obozrenie
- conflicts = obozrenie
- source = git+https://github.com/obozrenie/obozrenie.git
+ source = git+https://github.com/vorot93/obozrenie.git
sha512sums = SKIP
pkgname = obozrenie-git
diff --git a/PKGBUILD b/PKGBUILD
index f515baf91466..ce8df7b0d7f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,26 @@
-_pkgname=obozrenie
-pkgname=$_pkgname-git
-pkgver=r224.3f2815b
+_username=vorot93
+_reponame=obozrenie
+pkgname=obozrenie-git
+pkgver=r252.a113ab8
pkgrel=1
pkgdesc='Simple and easy to use game server browser'
arch=('any')
-url='http://github.com/obozrenie'
+url='https://github.com/vorot93/obozrenie'
license=('GPL3')
-depends=('desktop-file-utils' 'hicolor-icon-theme' 'gvfs' 'python-gobject'
- 'python-pytoml' 'python-xdg' 'gtk3' 'python-beautifulsoup4'
- 'python-xmltodict' 'qstat')
+depends=('desktop-file-utils' 'hicolor-icon-theme' 'gvfs' 'python-gobject' 'python-pytoml' 'python-xdg' 'gtk3' 'python-beautifulsoup4' 'python-xmltodict' 'qstat')
makedepends=('git' 'python-babel' 'python-setuptools')
-optdepends=('python-pygeoip: for geolocation support'
- 'geoip-database: for geolocation support')
-provides=('obozrenie')
-conflicts=('obozrenie')
+optdepends=('python-pygeoip: for geolocation support' 'geoip-database: for geolocation support')
install='obozrenie.install'
-source=('git+https://github.com/obozrenie/obozrenie.git')
+source=("git+https://github.com/$_username/$_reponame.git")
sha512sums=('SKIP')
pkgver() {
- cd "$_pkgname"
+ cd $_reponame
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- cd $_pkgname
+ cd $_reponame
python setup.py install --root="${pkgdir}" --optimize='1'
python setup.py compile_catalog -D io.obozrenie -d locale