summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rwxr-xr-xPKGBUILD27
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8e5a7c8cb824
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = obs-linuxbrowser-bin
+ pkgdesc = Browser source plugin for obs-studio based on CEF. Alternative to obs-qtwebkit.
+ pkgver = 0.3.1
+ pkgrel = 1
+ url = https://github.com/bazukas/obs-linuxbrowser
+ arch = x86_64
+ license = GPL
+ depends = obs-studio>=20.0.1
+ depends = gconf
+ depends = nss
+ depends = libxss
+ depends = pango
+ depends = atk
+ depends = libxrandr
+ depends = libxcomposite
+ optdepends = pepper-flash: Flash support
+ provides = obs-linuxbrowser
+ conflicts = obs-linuxbrowser
+ source = https://github.com/bazukas/obs-linuxbrowser/releases/download/0.3.1/linuxbrowser0.3.1-obs20.0.1-64bit.tgz
+ sha256sums = ae4e33d11dd3dc1aed440c7bcf1fb1da282cda39bc37fe771c900a7a4b468d28
+
+pkgname = obs-linuxbrowser-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..a448d4569706
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: NexAdn
+pkgname=obs-linuxbrowser-bin
+pkgver=0.3.1
+_obsver=20.0.1
+pkgrel=1
+pkgdesc="Browser source plugin for obs-studio based on CEF. Alternative to obs-qtwebkit."
+arch=("x86_64")
+url="https://github.com/bazukas/obs-linuxbrowser"
+license=("GPL")
+provides=("obs-linuxbrowser")
+conflicts=("obs-linuxbrowser")
+depends=(
+ "obs-studio>=${_obsver}"
+ "gconf" "nss" "libxss" "pango" "atk" "libxrandr" "libxcomposite"
+)
+optdepends=("pepper-flash: Flash support")
+source=(
+ "https://github.com/bazukas/obs-linuxbrowser/releases/download/${pkgver}/linuxbrowser${pkgver}-obs${_obsver}-64bit.tgz"
+)
+sha256sums=('ae4e33d11dd3dc1aed440c7bcf1fb1da282cda39bc37fe771c900a7a4b468d28')
+package() {
+ cd ${srcdir}/obs-linuxbrowser
+ install -d ${pkgdir}/usr/lib/obs-plugins/
+ install -d ${pkgdir}/usr/share/obs/obs-plugins/obs-linuxbrowser/
+ install -Dm755 ./bin/64bit/* ${pkgdir}/usr/lib/obs-plugins/
+ cp -R ./data/* ${pkgdir}/usr/share/obs/obs-plugins/obs-linuxbrowser/
+}