summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 4 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c5a9587749cd..8f9fbc6e3a4a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = obs-studio-tytan652
pkgdesc = Free and open source software for video recording and live streaming. With everything except service integrations. Plus V4L2 devices by paths, my bind interface PR, and sometimes backported fixes
pkgver = 28.0.3
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/obsproject/obs-studio
arch = x86_64
arch = aarch64
diff --git a/PKGBUILD b/PKGBUILD
index 3e42f1d39530..89259ed008b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ DISTRIB_ID=`lsb_release --id | cut -f2 -d$'\t'`
pkgname=obs-studio-tytan652
pkgver=28.0.3
-pkgrel=2
+pkgrel=3
pkgdesc="Free and open source software for video recording and live streaming. With everything except service integrations. Plus V4L2 devices by paths, my bind interface PR, and sometimes backported fixes"
arch=("x86_64" "aarch64")
url="https://github.com/obsproject/obs-studio"
@@ -129,10 +129,9 @@ fi
prepare() {
cd "$srcdir/obs-studio"
- git config --local protocol.file.allow always
git config submodule.plugins/obs-browser.url $srcdir/obs-browser
git config submodule.plugins/obs-websocket.url $srcdir/obs-websocket
- git submodule update
+ git -c protocol.file.allow=always submodule update
cd plugins/obs-websocket
sed -i 's|EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/deps/json/CMakeLists.txt||' CMakeLists.txt
@@ -140,9 +139,8 @@ prepare() {
sed -i 's|AND EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/deps/asio/asio/include/asio.hpp||' CMakeLists.txt
sed -i "s|AND EXISTS|EXISTS|" CMakeLists.txt
sed -i "s|add_subdirectory(deps/json)|find_package(nlohmann_json 3.10.0 REQUIRED)|" CMakeLists.txt
- git config --local protocol.file.allow always
git config submodule.deps/qr.url $srcdir/qr
- git submodule update deps/qr
+ git -c protocol.file.allow=always submodule update deps/qr
cd "$srcdir/obs-studio"
## Add network interface binding for RTMP on Linux (https://github.com/obsproject/obs-studio/pull/4219)