summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5584e7ae79c3..24510f56a43f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = obs-studio-tytan652
pkgdesc = Free and open source software for video recording and live streaming. Built with Browser and VST plugins and some patches but without FTL and Python.
pkgver = 26.1.2
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/obsproject/obs-studio
arch = i686
arch = x86_64
@@ -11,7 +11,6 @@ pkgbase = obs-studio-tytan652
makedepends = libfdk-aac
makedepends = libxcomposite
makedepends = x264
- makedepends = jack
makedepends = vlc
makedepends = swig
makedepends = luajit
@@ -20,12 +19,16 @@ pkgbase = obs-studio-tytan652
depends = jansson
depends = libxinerama
depends = libxkbcommon-x11
+ depends = mbedtls
+ depends = qt5-svg
depends = qt5-x11extras
depends = curl
+ depends = jack
depends = gtk-update-icon-cache
optdepends = libfdk-aac: FDK AAC codec support
optdepends = libxcomposite: XComposite capture support
- optdepends = jack: JACK Support
+ optdepends = libva-intel-driver: hardware encoding
+ optdepends = libva-mesa-driver: hardware encoding
optdepends = vlc: VLC Media Source
optdepends = swig: Scripting
optdepends = luajit: Lua scripting
diff --git a/PKGBUILD b/PKGBUILD
index a5c7c92633cc..86059309b264 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,22 @@
# Maintainer: tytan652 <tytan652 at tytanium dot xyz>
pkgname=obs-studio-tytan652
pkgver=26.1.2
-pkgrel=3
+pkgrel=4
pkgdesc="Free and open source software for video recording and live streaming. Built with Browser and VST plugins and some patches but without FTL and Python."
# Why no FTL ? Because Mixer is dead
# Why no Python ? Because it doesn't work out of the box with Python 3.9
arch=("i686" "x86_64")
url="https://github.com/obsproject/obs-studio"
license=("GPL2")
-depends=("ffmpeg" "jansson" "libxinerama" "libxkbcommon-x11"
- "qt5-x11extras" "curl" "gtk-update-icon-cache")
-makedepends=("cmake" "git" "libfdk-aac" "libxcomposite" "x264" "jack"
+depends=("ffmpeg" "jansson" "libxinerama" "libxkbcommon-x11" "mbedtls"
+ "qt5-svg" "qt5-x11extras" "curl" "jack" "gtk-update-icon-cache")
+makedepends=("cmake" "git" "libfdk-aac" "libxcomposite" "x264"
"vlc" "swig" "luajit" "cef-minimal-3770")
optdepends=(
"libfdk-aac: FDK AAC codec support"
"libxcomposite: XComposite capture support"
- "jack: JACK Support"
+ "libva-intel-driver: hardware encoding"
+ "libva-mesa-driver: hardware encoding"
"vlc: VLC Media Source"
"swig: Scripting"
"luajit: Lua scripting"