summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD31
-rw-r--r--obs-studio-tytan652.hook10
-rwxr-xr-xobs-studio-tytan652.sh20
4 files changed, 61 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ce67e6395563..6a114ba0c0f7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = obs-studio-tytan652
pkgdesc = Free and open source software for video recording and live streaming. With Browser dock and sources, VST 2 filter, FTL protocol, VLC sources, V4L2 devices by paths, my bind interface PR, and sometimes backported fixes.
pkgver = 27.1.3
- pkgrel = 11
+ pkgrel = 12
url = https://github.com/obsproject/obs-studio
arch = i686
arch = x86_64
@@ -13,6 +13,7 @@ pkgbase = obs-studio-tytan652
makedepends = swig
makedepends = luajit
makedepends = sndio
+ makedepends = lsb-release
makedepends = python>=3.10
makedepends = cef-minimal-obs=87.1.14
depends = jack
diff --git a/PKGBUILD b/PKGBUILD
index 8a2fba433420..f0564b6930ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,26 @@
# Maintainer: tytan652 <tytan652 at tytanium dot xyz>
+DISTRIB_ID=`lsb_release --id | cut -f2 -d$'\t'`
+
pkgname=obs-studio-tytan652
pkgver=27.1.3
-pkgrel=11
+pkgrel=12
pkgdesc="Free and open source software for video recording and live streaming. With Browser dock and sources, VST 2 filter, FTL protocol, VLC sources, V4L2 devices by paths, my bind interface PR, and sometimes backported fixes."
arch=("i686" "x86_64" "aarch64")
url="https://github.com/obsproject/obs-studio"
license=("GPL2")
+if [[ $DISTRIB_ID == 'ManjaroLinux' ]]; then
+_mbedtlsver=0
+_pythonver=0
+else
_mbedtlsver=2.28
_pythonver=3.10
+fi
depends=(
"jack" "gtk-update-icon-cache" "x264" "rnnoise" "pciutils"
# To manage mbedtls rebuild easily, this will prevent you to rebuild OBS on non-updated system
+ # For Manjaro user this feature is disabled
# Also OBS will need a patch when mbedtls 3 is on the repo
"mbedtls>=$_mbedtlsver" "mbedtls<3.0.0"
@@ -44,9 +52,10 @@ depends=(
## About ffmpeg-obs
# Read ffmpeg-obs PKGBUILD for more info
makedepends=(
- "cmake" "git" "libfdk-aac" "swig" "luajit" "sndio"
+ "cmake" "git" "libfdk-aac" "swig" "luajit" "sndio" "lsb-release"
# To manage python rebuild easily, this will prevent you to rebuild OBS on non-updated system
+ # For Manjaro user this feature is disabled
"python>=$_pythonver"
# AUR Packages
@@ -81,6 +90,17 @@ sha256sums=(
"SKIP"
)
+if [[ $DISTRIB_ID == 'ManjaroLinux' ]]; then
+source+=(
+ "$pkgname.hook"
+ "$pkgname.sh"
+)
+sha256sums+=(
+ "486b8297a7cabccd552a4d49f994b231f87860d32d4535906abf776eee2a377b"
+ "4fb9dcb408f9481127546db0c5287e1f1b274d14cf8975b0f02c1bafb23a4c37"
+)
+fi
+
if [[ $CARCH == 'x86_64' ]] || [[ $CARCH == 'i686' ]]; then
optdepends+=("decklink: Blackmagic Design DeckLink support")
fi
@@ -149,4 +169,11 @@ package() {
cd obs-studio/build
make install DESTDIR="$pkgdir"
+
+ if [[ $DISTRIB_ID == 'ManjaroLinux' ]]; then
+ mkdir -p "${pkgdir}"/usr/share/libalpm/hooks/
+ mkdir -p "${pkgdir}"/usr/share/libalpm/scripts/
+ install -D -m644 "$srcdir/$pkgname.hook" "${pkgdir}"/usr/share/libalpm/hooks/
+ install -D -m755 "$pkgname.sh" "${pkgdir}"/usr/share/libalpm/scripts/
+ fi
}
diff --git a/obs-studio-tytan652.hook b/obs-studio-tytan652.hook
new file mode 100644
index 000000000000..9007af0a364b
--- /dev/null
+++ b/obs-studio-tytan652.hook
@@ -0,0 +1,10 @@
+[Trigger]
+Type = Package
+Operation = Install
+Operation = Upgrade
+Target = obs-studio-tytan652
+
+[Action]
+Description = Warn Manjaro user about rebuild
+When = PostTransaction
+Exec = /usr/share/libalpm/scripts/obs-studio-tytan652.sh
diff --git a/obs-studio-tytan652.sh b/obs-studio-tytan652.sh
new file mode 100755
index 000000000000..f972109dfbd1
--- /dev/null
+++ b/obs-studio-tytan652.sh
@@ -0,0 +1,20 @@
+#!/bin/bash
+
+msg() {
+ALL_OFF="\\e[1;0m"
+BOLD="\\e[1;1m"
+GREEN="${BOLD}\\e[1;32m"
+local mesg=$1; shift
+printf "${GREEN}==>${ALL_OFF}${BOLD} ${mesg}${ALL_OFF}" "$@" >&2
+}
+
+echo
+msg "Warning:
+ -> obs-studio-tytan652 does not support Manjaro
+ -> officially.
+ -> Some dependency version checks are disabled to
+ -> allow the package to be built on it.
+ -> So the package may require to be rebuilt if some
+ -> dependency packages are updated. If not the
+ -> package could not work correctly.
+"