summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD25
2 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 63d7bf88e5a6..0cedbf1cab06 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = obs-text-pango
- pkgdesc = This plugin provides a text source for OBS Studio which is layed out and rendered using Pango
+ pkgdesc = Prefer obs-text-pthread instead | This plugin provides a text source for OBS Studio which is layed out and rendered using Pango
pkgver = 1.0
pkgrel = 2
url = https://github.com/kkartaltepe/obs-text-pango
@@ -13,4 +13,3 @@ pkgbase = obs-text-pango
sha256sums = 059b6364966f8c90044b27efc100136ca03e8093c69cc91c10b79b0f26640669
pkgname = obs-text-pango
-
diff --git a/PKGBUILD b/PKGBUILD
index 0bfc54ec6512..78d089a1ea8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: tytan652 <tytan652@tytanium.xyz>
+
pkgname=obs-text-pango
pkgver=1.0
pkgrel=2
-pkgdesc="This plugin provides a text source for OBS Studio which is layed out and rendered using Pango"
+pkgdesc="Prefer obs-text-pthread instead | This plugin provides a text source for OBS Studio which is layed out and rendered using Pango"
arch=('x86_64')
url="https://github.com/kkartaltepe/obs-text-pango"
license=("GPL2")
@@ -17,26 +18,28 @@ sha256sums=(
'059b6364966f8c90044b27efc100136ca03e8093c69cc91c10b79b0f26640669'
)
-prepare() {
- rm -rf fakeroot
-}
-
build() {
cd "$pkgname-$pkgver"
- patch -Np1 < "$srcdir"/updated_french.patch
+
+ patch -Np1 < $srcdir/updated_french.patch
+
cmake -B build \
-DOBS_INCLUDE_DIRS='/usr/include/obs' \
-DCMAKE_INSTALL_PREFIX='/'
+
make -C build
}
package() {
- mkdir -p "$pkgdir"/usr/lib/obs-plugins
- mkdir -p "$pkgdir"/usr/share/obs/obs-plugins
+ mkdir -p $pkgdir/usr/lib/obs-plugins
+ mkdir -p $pkgdir/usr/share/obs/obs-plugins
cd "$pkgname-$pkgver"
- make -C build DESTDIR="$srcdir/fakeroot/" install
- cp -a "$srcdir"/fakeroot/obs-plugins/64bit/libtext-pango.so "$pkgdir"/usr/lib/obs-plugins
- cp -a "$srcdir"/fakeroot/data/obs-plugins/text-pango "$pkgdir"/usr/share/obs/obs-plugins/
+ _fake_install_dir="$srcdir/plugin-install"
+
+ make -C build DESTDIR="$_fake_install_dir/" install
+
+ cp -a $_fake_install_dir/obs-plugins/64bit/libtext-pango.so $pkgdir/usr/lib/obs-plugins
+ cp -a $_fake_install_dir/data/obs-plugins/text-pango $pkgdir/usr/share/obs/obs-plugins/
} \ No newline at end of file