summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD39
2 files changed, 30 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 476af5e1697b..e4ac1a917f76 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,15 @@
+# Generated by mksrcinfo v8
+# Tue Feb 14 13:42:46 UTC 2017
pkgbase = obvious-git
- pkgdesc = Widgets for awesome wm (latest version)
- pkgver = 20100621
- pkgrel = 1
- url = https://github.com/hoelzro/obvious
- arch = any
- license = custom:MIT
- makedepends = git
- depends = awesome
+ pkgdesc = Widgets for awesome wm (latest version)
+ pkgver = r389.63cd248
+ pkgrel = 1
+ url = https://github.com/hoelzro/obvious
+ arch = any
+ license = custom:MIT
+ makedepends = git
+ depends = awesome
+ source = git+https://github.com/hoelzro/obvious.git
+ md5sums = SKIP
pkgname = obvious-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 326efcc59d96..74cbda2781be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,8 @@
+# Maintainer: Jeff Bowman <jeff dot t dot bowman at gmail dot com>
# Maintainer: Jesse R. Adams <jesse -at- techno -dash- geeks -dot- org>
+# Maintainer: Solomon Choina <shlomochoina at gmail dot com>
pkgname=obvious-git
-pkgver=20100621
+pkgver=r389.63cd248
pkgrel=1
pkgdesc="Widgets for awesome wm (latest version)"
arch=(any)
@@ -8,27 +10,22 @@ url="https://github.com/hoelzro/obvious"
license=('custom:MIT')
depends=('awesome')
makedepends=('git')
-source=()
-md5sums=()
-
-_gitroot=https://github.com/hoelzro/obvious.git
+source=(git+https://github.com/hoelzro/obvious.git)
+md5sums=(SKIP)
_gitname=obvious
-build() {
- cd "$srcdir"
- msg "Connecting to GIT server...."
-
- if [ -d $_gitname ] ; then
- cd $_gitname && git pull origin
- msg "The local files are updated."
- else
- git clone $_gitroot
- fi
-
- msg "GIT checkout done or server timeout"
+pkgver() {
+ cd "$_gitname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
- install -d ${pkgdir}/usr/share/awesome/lib/${_gitname} || return 1
- cp -a ${_gitname}/* ${pkgdir}/usr/share/awesome/lib/${_gitname} || return 1
- rm ${pkgdir}/usr/share/awesome/lib/${_gitname}/{AUTHORS,CONTRIBUTING.md,LICENSE,TODO} || return 1
- install -Dm644 ${_gitname}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE || return 1
+package() {
+ cd "$srcdir"
+ install -d ${pkgdir}/usr/share/awesome/lib/${_gitname}
+ cp -a ${_gitname}/* ${pkgdir}/usr/share/awesome/lib/${_gitname}
+ rm ${pkgdir}/usr/share/awesome/lib/${_gitname}/{AUTHORS,CONTRIBUTING.md,LICENSE,TODO}
+ install -Dm644 ${_gitname}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
}