summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7203746e9fe3..a1143226a09d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = ocaml-biniou
pkgdesc = An optimized parsing and printing library for JSON
pkgver = 1.2.2
- pkgrel = 6
+ pkgrel = 7
url = https://github.com/ocaml-community/biniou
arch = x86_64
license = BSD
makedepends = dune
depends = ocaml
depends = ocaml-easy-format
- depends = ocaml-findlib
depends = camlp-streams
provides = ocaml-biniou
options = !strip
diff --git a/PKGBUILD b/PKGBUILD
index 160a8e7cd322..fcfe1823a812 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@
_pkgname=biniou
pkgname=ocaml-${_pkgname}
pkgver=1.2.2
-pkgrel=6
+pkgrel=7
pkgdesc="An optimized parsing and printing library for JSON"
arch=('x86_64')
url="https://github.com/ocaml-community/${_pkgname}"
license=('BSD')
options=('!strip' 'staticlibs')
provides=('ocaml-biniou')
-depends=('ocaml' 'ocaml-easy-format' 'ocaml-findlib' 'camlp-streams')
+depends=('ocaml' 'ocaml-easy-format' 'camlp-streams')
makedepends=('dune')
source=("${url}/releases/download/${pkgver}/${_pkgname}-${pkgver}.tbz")
sha256sums=('8bf3ff17cd0ecb2d6b6d1d94cb08ef089d44caef96e9bae6be6839d428fa318f')
@@ -28,7 +28,7 @@ check() {
package() {
cd ${_pkgname}-${pkgver}
- DESTDIR="${pkgdir}" dune install --prefix=/usr --libdir="$(ocamlfind printconf destdir)"
+ DESTDIR="${pkgdir}" dune install --prefix=/usr --libdir="$(ocamlc -where)"
install -Dm644 LICENSE -t "${pkgdir}"/usr/share/licenses/${pkgname}/
rm -r "${pkgdir}"/usr/doc
}