summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 292f1ad9d62f..a1143226a09d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = ocaml-biniou
pkgdesc = An optimized parsing and printing library for JSON
- pkgver = 1.2.1
- pkgrel = 4
+ pkgver = 1.2.2
+ pkgrel = 7
url = https://github.com/ocaml-community/biniou
arch = x86_64
license = BSD
makedepends = dune
+ depends = ocaml
depends = ocaml-easy-format
+ depends = camlp-streams
provides = ocaml-biniou
options = !strip
options = staticlibs
- source = https://github.com/ocaml-community/biniou/releases/download/1.2.1/biniou-1.2.1.tbz
- sha256sums = 35546c68b1929a8e6d27a3b39ecd17b38303a0d47e65eb9d1480c2061ea84335
+ source = https://github.com/ocaml-community/biniou/releases/download/1.2.2/biniou-1.2.2.tbz
+ sha256sums = 8bf3ff17cd0ecb2d6b6d1d94cb08ef089d44caef96e9bae6be6839d428fa318f
pkgname = ocaml-biniou
-
diff --git a/PKGBUILD b/PKGBUILD
index 9d2b34a804ea..fcfe1823a812 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,18 @@
_pkgname=biniou
pkgname=ocaml-${_pkgname}
-pkgver=1.2.1
-pkgrel=4
+pkgver=1.2.2
+pkgrel=7
pkgdesc="An optimized parsing and printing library for JSON"
arch=('x86_64')
url="https://github.com/ocaml-community/${_pkgname}"
license=('BSD')
options=('!strip' 'staticlibs')
provides=('ocaml-biniou')
-depends=('ocaml-easy-format')
+depends=('ocaml' 'ocaml-easy-format' 'camlp-streams')
makedepends=('dune')
source=("${url}/releases/download/${pkgver}/${_pkgname}-${pkgver}.tbz")
-sha256sums=('35546c68b1929a8e6d27a3b39ecd17b38303a0d47e65eb9d1480c2061ea84335')
+sha256sums=('8bf3ff17cd0ecb2d6b6d1d94cb08ef089d44caef96e9bae6be6839d428fa318f')
build() {
cd ${_pkgname}-${pkgver}
@@ -28,7 +28,7 @@ check() {
package() {
cd ${_pkgname}-${pkgver}
- DESTDIR="${pkgdir}" dune install --prefix=/usr --libdir="$(ocamlfind printconf destdir)"
+ DESTDIR="${pkgdir}" dune install --prefix=/usr --libdir="$(ocamlc -where)"
install -Dm644 LICENSE -t "${pkgdir}"/usr/share/licenses/${pkgname}/
rm -r "${pkgdir}"/usr/doc
}