summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD7
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2f3cd10c1fa1..490dcc4cc484 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ocaml-core
pkgdesc = Industrial strength alternative to OCaml's standard library
- pkgver = 112.35.00
+ pkgver = 112.35.01
pkgrel = 1
url = https://github.com/janestreet/core
arch = i686
@@ -23,9 +23,10 @@ pkgbase = ocaml-core
depends = ocaml-pipebang
depends = ocaml-sexplib
depends = ocaml-variantslib
+ optdepends = ocaml-utop: for coretop support
options = !strip
- source = https://ocaml.janestreet.com/ocaml-core/112.35/files/core-112.35.00.tar.gz
- md5sums = e98f85426fd8c886ad6b5fb7fb1eec42
+ source = https://ocaml.janestreet.com/ocaml-core/112.35/files/core-112.35.01.tar.gz
+ md5sums = 2ae86d0d4571327d9b3393c48f9fc0cc
pkgname = ocaml-core
diff --git a/PKGBUILD b/PKGBUILD
index 405a61e98e0d..ed76a5eb1e4c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-core
-pkgver=112.35.00
+pkgver=112.35.01
pkgrel=1
license=('Apache')
arch=('i686' 'x86_64')
pkgdesc="Industrial strength alternative to OCaml's standard library"
url="https://github.com/janestreet/core"
depends=('ocaml' 'ocaml-bin_prot' 'camlp4' 'ocaml-comparelib' 'ocaml-core_kernel' 'ocaml-custom_printf' 'ocaml-enumerate' 'ocaml-fieldslib' 'ocaml-herelib' 'ocaml-pa_bench' 'ocaml-pa_ounit' 'ocaml-pa_structural_sexp' 'ocaml-pa_test' 'ocaml-pipebang' 'ocaml-sexplib' 'ocaml-variantslib')
+optdepends=('ocaml-utop: for coretop support')
makedepends=('ocaml-findlib')
source=("https://ocaml.janestreet.com/ocaml-core/$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/${pkgname#ocaml-}-${pkgver}.tar.gz")
options=('!strip')
-md5sums=('e98f85426fd8c886ad6b5fb7fb1eec42')
+md5sums=('2ae86d0d4571327d9b3393c48f9fc0cc')
build() {
cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
@@ -26,4 +27,6 @@ package() {
export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
mkdir -p "${OCAMLFIND_DESTDIR}/stublibs"
make install
+ install -Dm755 "corebuild" "${pkgdir}/usr/bin/corebuild"
+ install -Dm755 "coretop" "${pkgdir}/usr/bin/coretop"
}