summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 43cfcbc96cec..2aee0e3fc9fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
# Generated by mksrcinfo v8
-# Wed Mar 9 21:57:13 UTC 2016
+# Fri Jul 29 13:43:54 UTC 2016
pkgbase = ocaml-core
pkgdesc = Industrial strength alternative to OCaml's standard library
- pkgver = 113.24.02
+ pkgver = 113.33.03
pkgrel = 1
url = https://github.com/janestreet/core
arch = i686
arch = x86_64
license = Apache
makedepends = ocaml-findlib
+ makedepends = ocaml-js-build-tools
makedepends = opam
depends = ocaml
depends = ocaml-bin_prot
@@ -25,9 +26,9 @@ pkgbase = ocaml-core
depends = ocaml-variantslib
optdepends = ocaml-utop: for coretop support
options = !strip
- source = https://ocaml.janestreet.com/ocaml-core/113.24/files/core-113.24.02.tar.gz
+ source = https://ocaml.janestreet.com/ocaml-core/113.33/files/core-113.33.03.tar.gz
source = libdir.patch
- md5sums = dca84e2fe387ef193ee584f043dae6ee
+ md5sums = 3a8c63205917a85de8ed597c11c1fc76
md5sums = 7f0a951f1ac87385272ea7a6dd58762a
pkgname = ocaml-core
diff --git a/PKGBUILD b/PKGBUILD
index bfce693118cc..187240b7045c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-core
-pkgver=113.24.02
+pkgver=113.33.03
pkgrel=1
license=('Apache')
arch=('i686' 'x86_64')
@@ -9,11 +9,11 @@ pkgdesc="Industrial strength alternative to OCaml's standard library"
url="https://github.com/janestreet/core"
depends=('ocaml' 'ocaml-bin_prot' 'ocaml-core_kernel' 'ocaml-fieldslib' 'ocaml-ppx_assert' 'ocaml-ppx_bench' 'ocaml-ppx_driver' 'ocaml-ppx_expect' 'ocaml-ppx_inline_test' 'ocaml-ppx_jane' 'ocaml-sexplib' 'ocaml-typerep' 'ocaml-variantslib')
optdepends=('ocaml-utop: for coretop support')
-makedepends=('ocaml-findlib' 'opam')
+makedepends=('ocaml-findlib' 'ocaml-js-build-tools' 'opam')
source=("https://ocaml.janestreet.com/ocaml-core/$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/${pkgname#ocaml-}-${pkgver}.tar.gz"
"libdir.patch")
options=('!strip')
-md5sums=('dca84e2fe387ef193ee584f043dae6ee'
+md5sums=('3a8c63205917a85de8ed597c11c1fc76'
'7f0a951f1ac87385272ea7a6dd58762a')
prepare() {
@@ -24,13 +24,13 @@ prepare() {
build() {
cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
-
+
./configure --prefix /usr
make
}
package() {
cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
-
+
make install PREFIX="${pkgdir}/usr" LIBDIR="${pkgdir}$(ocamlc -where)"
}