summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b951d821a205..2f3cd10c1fa1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ocaml-core
pkgdesc = Industrial strength alternative to OCaml's standard library
- pkgver = 112.24.01
+ pkgver = 112.35.00
pkgrel = 1
url = https://github.com/janestreet/core
arch = i686
@@ -18,13 +18,14 @@ pkgbase = ocaml-core
depends = ocaml-herelib
depends = ocaml-pa_bench
depends = ocaml-pa_ounit
+ depends = ocaml-pa_structural_sexp
depends = ocaml-pa_test
depends = ocaml-pipebang
depends = ocaml-sexplib
depends = ocaml-variantslib
options = !strip
- source = https://ocaml.janestreet.com/ocaml-core/112.24/files/core-112.24.01.tar.gz
- md5sums = 4c4bc769e1dc8249b973f692994c5406
+ source = https://ocaml.janestreet.com/ocaml-core/112.35/files/core-112.35.00.tar.gz
+ md5sums = e98f85426fd8c886ad6b5fb7fb1eec42
pkgname = ocaml-core
diff --git a/PKGBUILD b/PKGBUILD
index c96173f5d3cd..405a61e98e0d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-core
-pkgver=112.24.01
+pkgver=112.35.00
pkgrel=1
license=('Apache')
arch=('i686' 'x86_64')
pkgdesc="Industrial strength alternative to OCaml's standard library"
url="https://github.com/janestreet/core"
-depends=('ocaml' 'ocaml-bin_prot' 'camlp4' 'ocaml-comparelib' 'ocaml-core_kernel' 'ocaml-custom_printf' 'ocaml-enumerate' 'ocaml-fieldslib' 'ocaml-herelib' 'ocaml-pa_bench' 'ocaml-pa_ounit' 'ocaml-pa_test' 'ocaml-pipebang' 'ocaml-sexplib' 'ocaml-variantslib')
+depends=('ocaml' 'ocaml-bin_prot' 'camlp4' 'ocaml-comparelib' 'ocaml-core_kernel' 'ocaml-custom_printf' 'ocaml-enumerate' 'ocaml-fieldslib' 'ocaml-herelib' 'ocaml-pa_bench' 'ocaml-pa_ounit' 'ocaml-pa_structural_sexp' 'ocaml-pa_test' 'ocaml-pipebang' 'ocaml-sexplib' 'ocaml-variantslib')
makedepends=('ocaml-findlib')
-source=("https://ocaml.janestreet.com/ocaml-core/$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/${pkgname#ocaml-}-$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")$([[ $(echo ${pkgver} | grep -Po "[0-9]+$") != "00" ]] && echo ".$(echo ${pkgver} | grep -Po "[0-9]+$")").tar.gz")
+source=("https://ocaml.janestreet.com/ocaml-core/$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/${pkgname#ocaml-}-${pkgver}.tar.gz")
options=('!strip')
-md5sums=('4c4bc769e1dc8249b973f692994c5406')
+md5sums=('e98f85426fd8c886ad6b5fb7fb1eec42')
build() {
cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"