summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD29
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b951d821a205
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = ocaml-core
+ pkgdesc = Industrial strength alternative to OCaml's standard library
+ pkgver = 112.24.01
+ pkgrel = 1
+ url = https://github.com/janestreet/core
+ arch = i686
+ arch = x86_64
+ license = Apache
+ makedepends = ocaml-findlib
+ depends = ocaml
+ depends = ocaml-bin_prot
+ depends = camlp4
+ depends = ocaml-comparelib
+ depends = ocaml-core_kernel
+ depends = ocaml-custom_printf
+ depends = ocaml-enumerate
+ depends = ocaml-fieldslib
+ depends = ocaml-herelib
+ depends = ocaml-pa_bench
+ depends = ocaml-pa_ounit
+ depends = ocaml-pa_test
+ depends = ocaml-pipebang
+ depends = ocaml-sexplib
+ depends = ocaml-variantslib
+ options = !strip
+ source = https://ocaml.janestreet.com/ocaml-core/112.24/files/core-112.24.01.tar.gz
+ md5sums = 4c4bc769e1dc8249b973f692994c5406
+
+pkgname = ocaml-core
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c96173f5d3cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=ocaml-core
+pkgver=112.24.01
+pkgrel=1
+license=('Apache')
+arch=('i686' 'x86_64')
+pkgdesc="Industrial strength alternative to OCaml's standard library"
+url="https://github.com/janestreet/core"
+depends=('ocaml' 'ocaml-bin_prot' 'camlp4' 'ocaml-comparelib' 'ocaml-core_kernel' 'ocaml-custom_printf' 'ocaml-enumerate' 'ocaml-fieldslib' 'ocaml-herelib' 'ocaml-pa_bench' 'ocaml-pa_ounit' 'ocaml-pa_test' 'ocaml-pipebang' 'ocaml-sexplib' 'ocaml-variantslib')
+makedepends=('ocaml-findlib')
+source=("https://ocaml.janestreet.com/ocaml-core/$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/${pkgname#ocaml-}-$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")$([[ $(echo ${pkgver} | grep -Po "[0-9]+$") != "00" ]] && echo ".$(echo ${pkgver} | grep -Po "[0-9]+$")").tar.gz")
+options=('!strip')
+md5sums=('4c4bc769e1dc8249b973f692994c5406')
+
+build() {
+ cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
+
+ ./configure --prefix /usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
+
+ export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
+ mkdir -p "${OCAMLFIND_DESTDIR}/stublibs"
+ make install
+}