summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0a71dd99587b..ed07910f2227 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
pkgbase = ocaml-curl
- pkgdesc = OCaml bindings to libcurl networking library
+ pkgdesc = OCaml bindings to libcurl
pkgver = 0.9.1
- pkgrel = 3
- url = https://github.com/ygrek/ocurl
+ pkgrel = 4
+ url = https://ygrek.org.ua/p/ocurl
arch = i686
arch = x86_64
arch = armv7h
- license = BSD
+ license = MIT
makedepends = ocaml-findlib
depends = ocaml
depends = curl>=7.28.0
options = !strip
options = !makeflags
options = staticlibs
- source = https://github.com/ygrek/ocurl/releases/download/0.9.1/ocurl-0.9.1.tar.gz
- sha256sums = c65f01913270b674a0ca0f278f91bc1e368d7110e8308084bc2280b43a0bc258
+ source = https://github.com/ygrek/ocurl/archive/0.9.1.tar.gz
+ md5sums = 98dd56308f4ab0859e549232b602a733
pkgname = ocaml-curl
diff --git a/PKGBUILD b/PKGBUILD
index 78fcb2517ed8..0702d76fcc42 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,16 @@
pkgname=ocaml-curl
pkgver=0.9.1
-pkgrel=3
-pkgdesc='OCaml bindings to libcurl networking library'
+pkgrel=4
+pkgdesc='OCaml bindings to libcurl'
arch=('i686' 'x86_64' 'armv7h')
-license=('BSD')
+license=('MIT')
depends=('ocaml' 'curl>=7.28.0')
makedepends=('ocaml-findlib')
options=('!strip' '!makeflags' 'staticlibs')
-url='https://github.com/ygrek/ocurl'
-source=("${url}/releases/download/${pkgver}/ocurl-${pkgver}.tar.gz")
-sha256sums=('c65f01913270b674a0ca0f278f91bc1e368d7110e8308084bc2280b43a0bc258')
+url='https://ygrek.org.ua/p/ocurl'
+source=("https://github.com/ygrek/ocurl/archive/${pkgver}.tar.gz")
+md5sums=('98dd56308f4ab0859e549232b602a733')
build() {
cd "${srcdir}/ocurl-${pkgver}"
@@ -25,4 +25,4 @@ package() {
export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
install -dm 755 "${OCAMLFIND_DESTDIR}/stublibs"
make install FINDLIB=ocamlfind
-}
+} \ No newline at end of file