summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2e5e4ae15248
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ocaml-fdkaac
+ pkgdesc = OCaml bingind for the fdk-aac library
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = https://github.com/savonet/ocaml-fdkaac
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = ocaml-findlib
+ depends = ocaml
+ depends = libfdk-aac
+ options = !strip
+ source = https://github.com/savonet/ocaml-fdkaac/releases/download/0.2.1/ocaml-fdkaac-0.2.1.tar.gz
+ md5sums = fff652fa282b4954d2f504ca1c2a70e9
+
+pkgname = ocaml-fdkaac
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e9ee5628925d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=ocaml-fdkaac
+pkgver=0.2.1
+pkgrel=1
+license=('GPL2')
+arch=('i686' 'x86_64')
+pkgdesc=("OCaml bingind for the fdk-aac library")
+url="https://github.com/savonet/ocaml-fdkaac"
+depends=('ocaml' 'libfdk-aac')
+makedepends=('ocaml-findlib')
+source=("https://github.com/savonet/ocaml-fdkaac/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz")
+options=('!strip')
+md5sums=('fff652fa282b4954d2f504ca1c2a70e9')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
+ mkdir -p "${OCAMLFIND_DESTDIR}/stublibs"
+ make install
+}